Bug #24815

Saving extension configuration fails

Added by Helmut Hummel about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2011-01-25
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

This has already been reported here:
http://forge.typo3.org/issues/12455

Moving the discussion to mantis to have all things in one place.

Original Description:
When trying to save the modified configuration of an extension, I get a message "Saving settings.." and eventually a flash message saying "Configuration was saved". Then pops up a Windows download dialogue about ajax.php.

The configuration changes were NOT saved.

The Backend log says: "Core: Error handler (BE): PHP Warning: array_pop() [<a href='function.array-pop'>function.array-pop</a>]: The argument should be an array in /.../t3lib/extjs/class.t3lib_extjs_extdirectrouter.php line 90"

(issue imported from #M17315)

#1

Updated by Helmut Hummel about 10 years ago

Additional note by Stan:

Hi Steffen,

I am trying to update the configuration of rtehtmlarea.

Posted request: extTID=6&extAction=ExtDirect&extMethod=saveExtensionConfiguration&extType=rpc&extUpload=false&extkey=rtehtmlarea&exttype=S&securityToken=e8bbda1670b9f2bed209fa0d6476b822&

Reply: [{"tid":"6","action":"ExtDirect","method":"saveExtensionConfiguration","type":"rpc","result":{"success":true,"data":null},"debug":""}]

Stan

#2

Updated by Helmut Hummel about 10 years ago

Another note from Phil:

Hello Helmut,

it is indeed a browser issue. The error happens with Opera (11).
However Chromium (10) works like it should.
Both on Fedora (64bit).

Best regards
Phil

#3

Updated by Stanislas Rolland about 10 years ago

Does not work in Firefox 4 beta 9.

Works fine in Firefox 3.6.13 and Chrome 8.0.552.

In Opera 11.0, the update is succesful, but I do get the request to download ajax.php and the error on the log.

In IE8, the configuration tab does not display. Fails with unknown runtime error in ext-all.

#4

Updated by Steffen Gebert about 10 years ago

So isn't this one solved with #24819?

#5

Updated by Helmut Hummel about 10 years ago

It's partly solved. There are still some troubles in FF4 and Opera10

#6

Updated by Helmut Hummel about 10 years ago

This had nothing to do with CSRF protection and is now solved in 4.5.2

Also available in: Atom PDF