Bug #24910

Performance Bottleneck when having several RTE fields at one data-entry

Added by Andreas Cord-Landwehr almost 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2011-01-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

For a company Typo3-Extension I have a plugin that has database entries with several text-fields for each entry. Those textfields are separeted by several tabs in the backend view (--div-- in TCA). Each of the textfield enables an RTE and the richtext editor is actually needed. In total these are >15 textfields with RTE for one entry.

Since upgrade to the 4.4.x series as well with 4.5.x (tested both with 4.4.6 and 4.5.0) the backend gets anusable when opening one of these database entries in backend to edit. It takes up to 5 min that all script elements are loaded and Firefox yells "Probable infinity loop script errors".

I set the severity to major, please correct me if you see this different. But I think this is a major bottleneck that should not be there.

(issue imported from #M17425)

#1

Updated by Andreas Cord-Landwehr almost 10 years ago

Forgot the important part: with RTE disabled the "old" speed for the backend is back. This meens the page is loaded fast and the backend is fully usable again.

#2

Updated by Kevin Ulrich Moschallski over 9 years ago

Hi Andreas,

i can reproduce this with an FCE element with a section which contains an RTE. I have a customer with such a FCE and approx. 30 entries. Firefox loads for about three minutes. No problem in webkit based browsers.

Do you have any bugfix for this yet?

#3

Updated by Andreas Cord-Landwehr over 9 years ago

Hi, my temporary workaround is to part the RTEs into several tabs (DIV elements in TCA plus tabbed view) and also convince my customer to use Chromium instead of Firefox. But it is obviously only a lousy workaround.

#4

Updated by Sigfried Arnold over 9 years ago

just replace it with tinymce_rte - since TinyMCE is way faster than HTMLArea.

In wonder why the antique HTMLArea is not switched to TinyMCE in the core by default.

#5

Updated by Andreas Cord-Landwehr over 9 years ago

Thx for the hint. TinyMCE actually brings enough boost to let the extension become usable again.

#6

Updated by Stanislas Rolland over 9 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • Target version deleted (0)
#7

Updated by Tim Lochm├╝ller about 7 years ago

Hey guys,

i can reproducse the issue too. We use TV with a section-FCE and the firefox loads many minutes or break and Chrome/Webkit have no problems?
Any suggestions? Is TinyMCE the only solution?

Regards,
Tim

#8

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber
  • Is Regression set to No

Can you retry on master?
Stan removed a lot of ExtJS overhead.

#9

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Mathias Schreiber)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF