Bug #25236

Access List: allowed excludefields shows multiple entries with same label

Added by Michael Schams over 11 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2011-03-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

When editing a BE user or user group, administrators can select entries for "allowed excludefields" from a huge list. Some of the entries show repeated labels, so a label (e.g. "Page Content: Align") occurs more than once, see attached screenshot.

It is important to understand that this list depends on the installed/loaded extensions and that (since TYPO3 v4.5.x) the tool tip (circled question mark, right hand side) often shows some useful hints about the meaning of the entry but nevertheless, the repeated occurrence of entries with the same label is confusing and causes setting wrong permissions for users/groups.

(issue imported from #M17842)


Files

typo3bug-17842.png (44 KB) typo3bug-17842.png Administrator Admin, 2011-03-03 02:27
allowed_excludefields.png (84.8 KB) allowed_excludefields.png Francois Suter, 2011-11-04 13:49
#1

Updated by Navi almost 11 years ago

  • Target version changed from 0 to 4.5.8

This is a really important issue.

Could someone look into this please?

#2

Updated by Francois Suter almost 11 years ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Complexity set to hard

I can confirm the issue and it's indeed quite serious. The problem is not about repeated entries. It's that several entries have the same label since TYPO3 4.5. This is clearly a consequence of the reorganization of the pages, tt_content and page_language_overlays TCA entries. I will take a deeper look into that today, I'm not sure what the best solution is.

#3

Updated by Francois Suter almost 11 years ago

  • Priority changed from Must have to Should have
  • Complexity changed from hard to medium

My first hypothesis is absolutely wrong. This issue has actually been around for ages. For example, the tt_content table has always had three fields whose label is "Align:". The difference is that - since TYPO3 4.5 - the entries for the exclude fields selection are sorted alphabetically, which makes the identically-labeled fields stand out.

I'll keep digging and trying to come up with a solution. Maybe display the field's actual name next to its label.

#4

Updated by Francois Suter almost 11 years ago

Here's a screenshot of my proposal. I'm going to submit the related patch now.

#6

Updated by Francois Suter almost 11 years ago

  • Complexity changed from medium to easy

Furthermore I think this can be very useful for administrators when you happen to know precisely the field's name (e.g. from the database) but are unsure of its label.

#7

Updated by Mr. Hudson almost 11 years ago

  • Status changed from Accepted to Under Review

Patch set 1 of change I503c8a2e547c749a8bdcc19d70abe2d2471e6650 has been pushed to the review server.
It is available at http://review.typo3.org/6543

#8

Updated by Francois Suter almost 11 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF