Project

General

Profile

Actions

Bug #25274

closed

apc backend uncaught exception "Could not set value"

Added by Ralf Strobel about 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2011-03-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.4
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Ever since I've been using the apc caching backend, I get error reports about twice a day, notifying me of an uncaught exception "Could not set value".

I have not noticed any negative effects on the site functionality or received any complaints from users.

Extension: Core: Exception handler (WEB)
Severity: 4

Uncaught TYPO3 Exception: #1232986877: Could not set value. | t3lib_cache_Exception thrown in file (...)/t3lib/cache/backend/class.t3lib_cache_backend_apcbackend.php in line 131

(issue imported from #M17886)

Actions #1

Updated by Andreas Kiessling about 13 years ago

Did you have a look at the memory usage? I had an error with not enough memory set for apc, but don't remember the exact message. Only happened on a Debian server, not on my local OSX setup, so maybe it also depends on your apc version.
How to check: http://www.antusblog.de/2009/08/12/apc-status-und-uberwachung/

Actions #2

Updated by Ralf Strobel about 13 years ago

I did check that, but could find no clues to the origin of the error. I have assigned 256 megabytes of memory to apc and it is by far not used up.

In either case, since this does not seem to cause a fatal error in the frontend, I think Typo3 should catch the exception and handle it as severity 3.

Actions #3

Updated by Christian Weiske about 10 years ago

  • Target version deleted (0)

Reason for this error is that apc.enable_cli is set to 0. The APC backend cannot be used on CLI in that case.

Actions #4

Updated by Gerrit Code Review about 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28035

Actions #5

Updated by Gerrit Code Review about 10 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28035

Actions #6

Updated by Gerrit Code Review about 10 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28035

Actions #7

Updated by Christian Weiske about 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Job Rutgers almost 10 years ago

I still get the "Could not set value" error.

I have the following APC options:

apc.enabled=1
apc.shm_segments=1
apc.shm_size=128M
apc.stat=0
apc.canonicalize=1
apc.filters="-typo3temp/.*,-/usr/share/phpmyadmin/.*" 

And I tried apc.enable_cli = 1 and = 0
Setting up those values in /etc/php5/conf.d20-apc.ini or in /etc/php5/fpm/php.ini make no sense.

I run Typo3 6.2.4 with nginx 1.2.1 and php5-fpm and APC 3.1.13

Actions #9

Updated by Kurt Gusbeth over 6 years ago

  • Description updated (diff)

This bug is still alive in TYPO3 7.6.23:

Uncaught TYPO3 Exception
#1232986277: Could not set value. (More information)
TYPO3\CMS\Core\Cache\Exception thrown in file
/html/typo3/typo3_src-7.6.23/typo3/sysext/core/Classes/Cache/Backend/ApcuBackend.php in line 150.
9 TYPO3\CMS\Core\Cache\Backend\ApcuBackend::set("eff35d946f224e8fc1e75c87c720db2a", "a:19:{s:7:"plugin.";a:14:{s:16:"tx_indexedsearch";…:4:"page";i:7076;s:23:"fluidAjaxWidgetResponse";}}", array, 0)
/html/typo3/typo3_src-7.6.23/typo3/sysext/core/Classes/Cache/Frontend/VariableFrontend.php:
00083: $this->backend->set($entryIdentifier, igbinary_serialize($variable), $tags, $lifetime);
00084: } else {
00085: $this->backend->set($entryIdentifier, serialize($variable), $tags, $lifetime);
00086: }
Actions #10

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF