Bug #25352

Removing child records in a workspace does not work

Added by Oliver Hader over 8 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
-
Target version:
-
Start date:
2011-03-17
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The following issues on removing IRRE child records in a workspace(!) have been identified:

1) Removing children in TCEforms

Parent
+ Child A
+ Child A.A
+ Child A.B
+ Child B

On removing the branch of "Child A" (including both sub-children), the
"Child A" as well as the sub-children "A.A" and "A.B" do not appear in
the workspace module as removed or modified.

2) Removing children in the list view

(same structure as shown at the first point)

On again removing the branch of "Child A", the "Child A" is shown as
removed, but the sub-children "A.A" and "A.B" are shown with regular
modifications, but not as deleted.

3) Reverting changes in the workspace module

Now imagine the the top-parent "Parent" gets removed and this change to
the "Parent" will be reverted in the workspace module. Then this should
automatically also affect all children.

(issue imported from #M17981)


Related issues

Blocked by TYPO3 Core - Bug #13941: Removing child records in a workspace does not work Closed 2011-03-21

Associated revisions

Revision 185ae5a0 (diff)
Added by Oliver Hader over 8 years ago

[BUGFIX] Removing child records in a workspace does not work

These parts are not working with IRRE in workspaces:
Removing children in TCEforms
Removing children in the list view
Reverting changes in the workspace module

Change-Id: I91313235e57c193e7103d065c02d2005ef74ab86
Resolves: #25352
Releases: 4.6, 4.5
Reviewed-on: http://review.typo3.org/1195
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision 9f7cc168 (diff)
Added by Oliver Hader over 8 years ago

[BUGFIX] Removing child records in a workspace does not work

These parts are not working with IRRE in workspaces:
Removing children in TCEforms
Removing children in the list view
Reverting changes in the workspace module

Change-Id: I79904c636772f6fcd7fcfe1fc6e136e9e2e19d98
Resolves: #25352
Releases: 4.6, 4.5
Reviewed-on: http://review.typo3.org/1986
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#2 Updated by Oliver Hader over 8 years ago

I had to introduce a new class t3lib_utility_registry_MemoryRegistry (which is basically the same as t3lib_registry, but does not store the information in the database - so it's just the default registry pattern). This was required since on removing a child record in the TCEforms view and saving it the following happens:
  • submit "data" parameters of the visible elements and "cmd" parameters of the deleted child record to TCEmain
  • process_datamap is called before process_cmdmap (thus, removing happens later)
  • process_datamap then will create a new version of the child record
  • process_cmdmap will remove the created version of the previous step, but thus won't create the delete placeholder

To cirumvent this and the nested TCEmain objects inside TCEmain, I needed a way to keep the information about elements that will be deleted to skip them.
It might be difficult to introduce this to TYPO3 4.5 - however something like this is required here and I did not want to start with anonymous objects or a new $GLOBAL array...

#3 Updated by Steffen Kamper over 8 years ago

As this is a very complex issue, could you add a step-by-step reproduce info, i guess with the IRRE-tutorial extension? i would like to verify this issue.

#4 Updated by Susanne Moog over 8 years ago

  • Target version deleted (4.5.3)

#5 Updated by Mr. Hudson over 8 years ago

Patch set 11 of change I91313235e57c193e7103d065c02d2005ef74ab86 has been pushed to the review server.
It is available at http://review.typo3.org/1195

#6 Updated by Mr. Hudson over 8 years ago

Patch set 12 of change I91313235e57c193e7103d065c02d2005ef74ab86 has been pushed to the review server.
It is available at http://review.typo3.org/1195

#7 Updated by Mr. Hudson over 8 years ago

Patch set 13 of change I91313235e57c193e7103d065c02d2005ef74ab86 has been pushed to the review server.
It is available at http://review.typo3.org/1195

#8 Updated by Mr. Hudson over 8 years ago

Patch set 1 of change I79904c636772f6fcd7fcfe1fc6e136e9e2e19d98 has been pushed to the review server.
It is available at http://review.typo3.org/1986

#9 Updated by Oliver Hader over 8 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF