Bug #27098

Fatal error when downloading extension files

Added by Jeff Segars over 8 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
Start date:
2011-05-27
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When attempting to download files from the "Edit Files" page in the Extension Manager, a fatal error occurs. This is because the downloadFile URL parameter is not decoded first.

#1270853980: TYPO3 Fatal Error: Error while trying to download the extension file... 

RuntimeException thrown in file
/usr/bin/wecsharedsource/typo3_src-trunk/typo3/sysext/em/classes/index.php in line 1677.

3 SC_mod_tools_em_index::showExtDetails("felogin")

/usr/bin/wecsharedsource/typo3_src-trunk/typo3/sysext/em/classes/index.php:
00432:   // Command given which is executed regardless of main menu setting:
00433:   if ($this->CMD['showExt']) { // Show details for a single extension
00434:    $this->showExtDetails($this->CMD['showExt']);
00435:   } elseif ($this->CMD['requestInstallExtensions']) { // Show details for a single extension
00436:    $this->requestInstallExtensions($this->CMD['requestInstallExtensions']);

2 SC_mod_tools_em_index::main()

/usr/bin/wecsharedsource/typo3_src-trunk/typo3/sysext/em/classes/index.php:
02594: $SOBE->checkExtObj();
02595: 
02596: $SOBE->main();
02597: $SOBE->printContent();
02598: 

1 require("/usr/bin/wecsharedsource/typo3_src-trunk/typo3/sysext/em/classes/index.php")

/usr/bin/wecsharedsource/typo3_src-trunk/typo3/mod.php:
00049:  require($temp_path . 'conf.php');
00050:  $BACK_PATH = '';
00051:  require($temp_path . 'index.php');
00052:  $isDispatched = TRUE;
00053: } else {

27098.diff View (794 Bytes) Jeff Segars, 2011-05-27 21:37

Associated revisions

Revision f116eea8 (diff)
Added by Markus Klein about 8 years ago

[BUGFIX] EM, Error when downloading extension files

Trying to download a file using the Edit Files page of the old EM
leads to a fatal error, because URL is not decoded properly.

Change-Id: Ibd8f71fbc0ff8d9761b35cde713c3c021c6eb31e
Resolves: #27098
Releases: 4.6, 4.5
Reviewed-on: http://review.typo3.org/5579
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers
Reviewed-by: Stefan
Tested-by: Stefan
Reviewed-by: Steffen Gebert
Tested-by: Steffen Gebert

Revision cb13eae2 (diff)
Added by Markus Klein about 8 years ago

[BUGFIX] EM, Error when downloading extension files

Trying to download a file using the Edit Files page of the old EM
leads to a fatal error, because URL is not decoded properly.

Change-Id: I6980a0fbe8967bff0df0d8d7bc4c8f1abf53615e
Resolves: #27098
Releases: 4.6, 4.5
Reviewed-on: http://review.typo3.org/5578
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers
Reviewed-by: Stefan
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Steffen Gebert
Tested-by: Steffen Gebert

History

#1 Updated by Jeff Segars over 8 years ago

Looks like we just need to urldecode() the filename.

#2 Updated by Stefan no-lastname-given about 8 years ago

I can confirm that the issue also exists in Typo3 4.5.6 and the attached patch fixed the issue for me as well.

Would be great if this fix could also be backported to the 4.5-branch.

#3 Updated by Markus Klein about 8 years ago

Just as a note: This is about the OLD EM!

#4 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change I6980a0fbe8967bff0df0d8d7bc4c8f1abf53615e has been pushed to the review server.
It is available at http://review.typo3.org/5578

#5 Updated by Mr. Hudson about 8 years ago

Patch set 1 of change Ibd8f71fbc0ff8d9761b35cde713c3c021c6eb31e has been pushed to the review server.
It is available at http://review.typo3.org/5579

#6 Updated by Steffen Gebert about 8 years ago

  • Target version set to 4.5.7
  • TYPO3 Version changed from 4.6 to 4.5

I would say this does not apply to master, as the old EM modules have been dropped there.

#7 Updated by Markus Klein about 8 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100

#8 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF