Bug #28313

Bug #25767: Unable to switch workspace as an editor

Javascript-Error when be_user has no access to module "Workspaces"

Added by Christian Baer over 9 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-07-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

There is a JS-Error coming from that scenario:

- be_user has no access to module "Workspaces"
- then the link to the Workspace-module is not rendered into DOM
- then in the file typo3/sysext/workspaces/Resources/Public/JavaScript/workspacemenu.js, there is this line:

Event.observe('goToWsModule', 'click', this.goToWorkspaceModule.bind(this));

- this produces the js-error: "_prototypeEventID not defined"

Solution (patch):

if(Ext.getBody().is('#goToWsModule')){
Event.observe('goToWsModule', 'click', this.goToWorkspaceModule.bind(this));
}


Related issues

Is duplicate of TYPO3 Core - Bug #13585: Workspaces cannot be changed with the topbar switcherClosedTolleiv Nietsch2011-03-03

Actions
#1

Updated by Stefan Neufeind over 9 years ago

Already fixed for 4.6 with #13585. Will see to get that backported to the 4.5-branch.

#2

Updated by Tolleiv Nietsch over 9 years ago

  • Status changed from New to Closed
  • Parent task set to #25767

Duplicate of #25767 - thanks for confirming ;)

#3

Updated by Michael Stucki over 7 years ago

  • Category set to Workspaces

Also available in: Atom PDF