Bug #25767

Unable to switch workspace as an editor

Added by Helmut Hummel over 10 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Category:
Workspaces
Target version:
Start date:
2011-07-19
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

It is not possible to switch into a workspace as an editor if he or she has no access to the workspace module.

To my understanding the workspace module should not be mandatory.

At least it is a bug, that the selector is shown if this restriction is intentional.


Subtasks

Bug #28313: Javascript-Error when be_user has no access to module "Workspaces"Closed2011-07-19

Actions
#1

Updated by Susanne Moog over 10 years ago

  • Status changed from New to Accepted
#2

Updated by Oliver Hader over 10 years ago

  • Target version changed from 4.5.3 to 4.5.3
#3

Updated by Oliver Hader over 10 years ago

  • Target version changed from 4.5.3 to 4.5.3
#4

Updated by Oliver Hader over 10 years ago

The workspace selector should only be shown if the module is shown...

#5

Updated by Michael Klapper about 10 years ago

  • Status changed from Accepted to Needs Feedback
  • TYPO3 Version set to 4.6

Unable to reproduce.

Can you provide some detailed steps how to reproduce this issue?

#6

Updated by Michael Klapper about 10 years ago

  • Target version deleted (4.5.3)
#7

Updated by Lucas Thurston about 10 years ago

I've got some detail on this one as I just encountered it today. This is happening in 4.5.3.

The issue is that for non-admin content editors who have access to more than one workspace, the workspace switcher interface at the top of the page does not actually bring up the clicked workspace unless the Workspaces module is installed. The workspaces that the user has access to are listed, but she cannot switch from one to the other -- the link doesn't do anything beyond closing the drop down menu.

If, on the other hand, you have a user who has access to only one workspace (live or another workspace), that user will be able to access that workspace because no switching is needed. If, for example, I have a workspace called Redesign 2011 and I grant a non-admin editor access to this workspace and not to live, they will be logged in this workspace. If I grant them access to the live workspace as well, they will not be able to switch out of the Redesign 2011 workspace until I also give them access to the workspaces module.

It seems odd that the user has access but cannot switch without have the Workspaces module installed (which in some cases you do not want to do!), so this feels like a bug.

I hope this helps.

#8

Updated by Tolleiv Nietsch almost 10 years ago

  • Status changed from Needs Feedback to Accepted
#9

Updated by Mr. Hudson almost 10 years ago

Patch set 1 of change I233402e3552a3f025cc7a2b76b2a9ea96126af42 has been pushed to the review server.
It is available at http://review.typo3.org/4539

#10

Updated by Tolleiv Nietsch almost 10 years ago

  • Status changed from Accepted to Under Review
  • Assignee set to Tolleiv Nietsch

From what I found it's actually possible to switch but the topbar doesn't reflect this - patch makes sure the workspace-label is always included in the topbar even for normal editors.

#11

Updated by Tolleiv Nietsch almost 10 years ago

  • Target version set to 4.5.6
#12

Updated by Mr. Hudson almost 10 years ago

Patch set 1 of change I4ab162d50b253101559f8baf6a45a213eb12fb21 has been pushed to the review server.
It is available at http://review.typo3.org/4928

#13

Updated by Tolleiv Nietsch almost 10 years ago

  • Status changed from Under Review to Resolved

Applied in changeset commit:ba04cfb60e2ef8ac3a9264ecc248ef998f20f438.

#14

Updated by Michael Stucki over 7 years ago

  • Category changed from Bugs to Workspaces
#15

Updated by Michael Stucki over 7 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#16

Updated by Riccardo De Contardi almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF