Bug #28606

Issue with Select Fields

Added by Marcus Schwemer almost 10 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2011-07-31
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
FormWizard
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

if a form contains select fields, I get an php error in the frontend.

PHP Fatal error: Call to a member function saveXML() on a non-object in [...]/typo3/sysext/form/Classes/View/Mail/Html/Html.php on line 113

or

PHP Fatal error: Call to a member function saveXML() on a non-object in [...]/typo3/sysext/form/Classes/View/Confirmation/Confirmation.php on line 105

How to reproduce:
- Create a new form
- Add a select field with some options (wizard default are sufficient)
- Add a Submit Button
- Go to the Frontend and send the form
- Result is a blank page

I can only recover from this error by deleting the fe_typo_user - cookie manually. Otherwise I get everytime the confirmation page.

Kind regards,
Marcus

#1

Updated by Oliver Hader over 9 years ago

  • Tags set to FormWizard
#2

Updated by Oliver Hader over 9 years ago

  • Project changed from Form to TYPO3 Core
#3

Updated by Oliver Hader over 9 years ago

  • Category set to Form Framework
#4

Updated by Oliver Hader over 9 years ago

  • Status changed from New to Needs Feedback
  • PHP Version set to 5.3
  • TYPO3 Version set to 4.6

I could not reproduce this anymore. Can you please double-check that again with TYPO3 4.6.0 RC1?

#5

Updated by Benedict over 9 years ago

I reproduced that Bug, if there is no validation and no data is send, this error occurs.

#6

Updated by Manuel over 9 years ago

In Typo3 4.6.5 I have the same error.

#7

Updated by Gerrit Code Review about 9 years ago

  • Status changed from Needs Feedback to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/11361

#8

Updated by Gerrit Code Review about 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/11361

#9

Updated by Gerrit Code Review about 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/11361

#10

Updated by Sebastian Schawohl almost 9 years ago

With TYPO3 4.6.8 I had similar issues.

My field name has space in it, and when I removed all the spaces, the form works perfectly. Maybe is it related to #35015?

#11

Updated by Gerrit Code Review over 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/11361

#12

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/17922

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/17923

#14

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at https://review.typo3.org/17924

#15

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch master_new has been pushed to the review server.
It is available at https://review.typo3.org/18587

#17

Updated by Christian Kuhn over 8 years ago

  • Status changed from Under Review to Resolved
#18

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF