Bug #29785

felogin redirect Error with showLogoutFormAfterLogin

Added by Gernot Ploiner about 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
felogin
Target version:
Start date:
2011-09-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If in typoscript this ist set:

plugin.tx_felogin_pi1 {
showLogoutFormAfterLogin = 1
}

then the Login Redirect does not work in all variants.

Usualy this isn't a problem, because when you redirect to anothe page there is automatically the logout view.
But if there are 2 felogin-plugins on one page (Login in the Content area, Logout in the Top of the Webpage) an there is a login based on usergroups (one group redirects, and another not), then the problem appears.

I hope you understand my bad english. If not, i can write better in native german.

#1

Updated by Tobias Liebig about 10 years ago

the redirect seems to be disabled explicitly, when setting the "showLogoutFormAfterLogin".

If you have two different usergroups, which should behave different, a work around might be setting the "showLogoutFormAfterLogin" depending on the usergroup:


[usergroup = 12]
plugin.tx_felogin_pi1.showLogoutFormAfterLogin = 1
[global]
#2

Updated by Tobias Liebig about 10 years ago

  • Priority changed from Must have to Should have
#3

Updated by Gernot Ploiner about 10 years ago

Ok, you should add this to the manual, because there are a lot of Postings in Forums.
Also that redirection does not work, when the content element is hidden when logged in. Solution:

plugin.tx_felogin_pi1 {
templatefile =
}

#4

Updated by Alexander Bigga about 10 years ago

  • Assignee set to Steffen Kamper

Gernot Ploiner wrote:

Ok, you should add this to the manual, because there are a lot of Postings in Forums.

Yes. The documentation about this feature is really bad. I was looking for hours for a solution, why redirect doesn't work at all on my installation.

And the only reason was, that I activated showLogoutFormAfterLogin because the docu told me "If set, you see direct the logout form after successful login". This sound reasonable to me but disables indeed the redirection :-(

Alexander

#5

Updated by Chris topher about 10 years ago

  • Target version changed from 4.5.7 to 4.5.8
#6

Updated by Gernot Ploiner almost 10 years ago

  • Target version changed from 4.5.8 to 4.5.11

There is another Problem with redirection, when you have more than one Storagefolders:
If you use the recursive Setting in Typoscript or in the Contentelement, the userLogin-redirection does not work.
Also when you add more than one Storage Pages in the Content Element.
It only works, when you add more pages with Typoscript:
Working Example:
storagePid = 972,41

Tested with TYPO3 4.5.10

#7

Updated by Ernesto Baschny almost 10 years ago

  • Target version changed from 4.5.11 to 4.5.12
#8

Updated by Xavier Perseguers almost 10 years ago

  • Assignee deleted (Steffen Kamper)
#9

Updated by Jigal van Hemert almost 9 years ago

  • Status changed from New to Closed

Some releases ago a note was added to the showLogoutFormAfterLogin option to warn about the effects for the redirect feature.

Gernot Krause: please open a new issue for other bugs.

#10

Updated by hwt3 no-lastname-given over 6 years ago

Yes, there is a hint in the documentation. But this behaviour isn't locial for me, at least from the non-technical point of view.

Why isn't it possible to enable the option to show the logout form after login and use this as default, if no redirect is set? Are there technical reasons or anything in the logic I don't see?

Also available in: Atom PDF