Project

General

Profile

Actions

Bug #30043

closed

Linkvalidator calls hook fetchType in analyseTypoLinks with currentR=null

Added by Björn Pedersen almost 13 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Linkvalidator
Target version:
Start date:
2011-09-19
Due date:
% Done:

100%

Estimated time:
0.10 h
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

As there are pathes through analyseTypoLinks where currentR is not set, it can happen that the fetchType hook gets called with currentR=null. This throws an API error as the fetchType interface requires the first arg to be an array.

Actions #1

Updated by Björn Pedersen almost 13 years ago

Solution: initialize $currentR as array().

Actions #2

Updated by Philipp Gampe almost 13 years ago

  • Status changed from New to Accepted
  • PHP Version set to 5.3
  • Complexity set to no-brainer

Hi Björn, thanks for your feedback and the proposed solution.

Do you mind pushing a patch to gerrit?

Actions #3

Updated by Mr. Hudson almost 13 years ago

Patch set 1 of change I2d517b8c57678e645c590b51d50343c42a3d36a9 has been pushed to the review server.
It is available at http://review.typo3.org/5097

Actions #4

Updated by Mr. Hudson almost 13 years ago

Patch set 2 of change I2d517b8c57678e645c590b51d50343c42a3d36a9 has been pushed to the review server.
It is available at http://review.typo3.org/5097

Actions #5

Updated by Björn Pedersen almost 13 years ago

  • Status changed from Accepted to Resolved
  • % Done changed from 0 to 100
Actions #6

Updated by Philipp Gampe almost 13 years ago

  • Status changed from Resolved to New
  • Assignee set to Philipp Gampe
  • Target version set to 4.6.0-beta3
  • % Done changed from 100 to 50
  • Estimated time set to 0.10 h

This went to core directly... this time it is good, because I have not time to prepare the merge for beta3 and this was the only change.

However this needs to be ported to linkvalidator repository. I will do this either today or tomorrow.

Actions #7

Updated by Oliver Hader almost 13 years ago

  • Target version changed from 4.6.0-beta3 to 4.6.0-RC1
Actions #8

Updated by Mr. Hudson almost 13 years ago

Patch set 1 of change Ic124938c8744c8ef412013499ad368e5b7966d9f has been pushed to the review server.
It is available at http://review.typo3.org/5289

Actions #9

Updated by Björn Pedersen almost 13 years ago

  • Status changed from New to Resolved
  • % Done changed from 50 to 100

Applied in changeset commit:74a9c140a82329b6e5b1ece65ba7f75c01f06cbb.

Actions #10

Updated by Chris topher over 12 years ago

  • Status changed from Resolved to Closed
Actions #11

Updated by Michael Stucki over 10 years ago

  • Category set to Linkvalidator
Actions #12

Updated by Michael Stucki over 10 years ago

  • Project changed from 1510 to TYPO3 Core
  • Category changed from Linkvalidator to Linkvalidator
Actions

Also available in: Atom PDF