Bug #30406

TCA: Fields with eval md5 can not be cleared

Added by Sebastian Michaelsen about 8 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2011-09-29
Due date:
% Done:

0%

Estimated time:
3.00 h
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
No
Sprint Focus:

Description

Try this: Open a Backend User record and try to use the little 'x' to clear the password field. The field is not cleared.

I pinned it down to the 'eval' => 'md5' configuration. Any fields with this md5-option (most likely password fields) will produce this error.

History

#1 Updated by Peter Niederlag about 8 years ago

  • Category set to DataHandler aka TCEmain
  • Status changed from New to Accepted
  • Priority changed from Should have to Could have
  • Target version deleted (4.6.0-RC1)
  • Estimated time set to 3.00 h
  • Complexity set to medium

confirmed, however clearing the field wont make to much sense most time anyway.

#2 Updated by Sebastian Michaelsen about 8 years ago

Peter Niederlag wrote:

confirmed, however clearing the field wont make to much sense most time anyway.

Don't get your point. I think clearing the field is quite straight forward if you want to set a new password. Actually I came accross this bug because I clicked the button and nothing happened.

#3 Updated by Mathias Schreiber almost 5 years ago

  • Status changed from Accepted to Resolved
  • Is Regression set to No

works on 7

#4 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF