Bug #30554

Reports module: Available services broken

Added by Lorenz Ulrich about 9 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2011-10-22
Due date:
2011-10-22
% Done:

100%

TYPO3 Version:
4.6
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Displaying the available services in the reports module is broken. This is a regression of removing the global declarations for TYPO4 4.6. In TYPO3 < 4.6 the global array $T3_SERVICES contained too much information:

$T3_SERVICES[$serviceType][$serviceKey] --> Information about a particular service
$T3_SERVICES[$serviceKey][$serviceKey] --> Same information

Because of this duplicate, the method t3lib_extMgm::findService could be "abused" to find out if a particular service was the service of highest priority of a type.

After the cleanup, the array $GLOBALS['T3_SERVICES'] only contains the information it is supposed to:

$T3_SERVICES[$serviceType][$serviceKey] --> Information about a particular service

Therefore t3lib_extMgm::findService($serviceKey, '*') will no longer work. This can be easily solved by adding a method that checks, if a particular service is the service of highest priority for the given service type.


Related issues

Follows TYPO3 Core - Task #31174: CGL cleanup in Available services report Closed 2011-10-21

Associated revisions

Revision 543f43d0 (diff)
Added by Lorenz Ulrich about 9 years ago

[BUGFIX] Reports module: Available services broken

Displaying the available services in the reports module is broken.
This is a regression due to cleaning up the global declarations for
services ($T3_SERVICES) in TYPO4 4.6.

Because of this method t3lib_extMgm::findService cannot be abused
into getting a service by its key explicitly. Hence a new method must
be introduced and used in the available services report.

This patch also introduces method t3lib_extMgm::isServiceAvailable
which refactors part of the services-related code to avoid
duplication.

Change-Id: I15fd7eecaafb52df0599598c5b700e458e63f0d9
Resolves: #30554
Releases: 4.6
Reviewed-on: http://review.typo3.org/5538
Reviewed-by: Lorenz Ulrich
Tested-by: Lorenz Ulrich
Reviewed-by: Steffen Gebert
Tested-by: Steffen Gebert

History

#1 Updated by Mr. Hudson about 9 years ago

Patch set 1 of change I15fd7eecaafb52df0599598c5b700e458e63f0d9 has been pushed to the review server.
It is available at http://review.typo3.org/5538

#2 Updated by Xavier Perseguers about 9 years ago

  • Target version changed from 4.6.0-RC1 to 4.6.0

#3 Updated by Xavier Perseguers about 9 years ago

  • Priority changed from Should have to Must have

#4 Updated by Mr. Hudson about 9 years ago

  • Status changed from New to Under Review

Patch set 2 of change I15fd7eecaafb52df0599598c5b700e458e63f0d9 has been pushed to the review server.
It is available at http://review.typo3.org/5538

#5 Updated by Mr. Hudson about 9 years ago

Patch set 3 of change I15fd7eecaafb52df0599598c5b700e458e63f0d9 has been pushed to the review server.
It is available at http://review.typo3.org/5538

#6 Updated by Lorenz Ulrich about 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF