Bug #31067

root-lines for DB Mounts in Pagetree rendering wrong markup

Added by Steffen Ritter over 8 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Pagetree
Target version:
Start date:
2011-10-18
Due date:
% Done:

100%

Estimated time:
1.00 h
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

While fixing #28687 it had been encountered that the option

options.pageTree.showPathAboveMounts = 1
which shows the rootline of each DB Mount is implemented in non-valid way, which means that a <div> tag had been rendered within an <ul> before the <li> of the DB Mount node.

After fixing #28687 this lead to optical issues on first render.


Related issues

Related to TYPO3 Core - Bug #28687: pagetree broken due to js exception Closed 2011-08-02

Associated revisions

Revision 6f61a644 (diff)
Added by Steffen Ritter over 8 years ago

[BUGFIX] root-lines for DB Mounts in Pagetree rendering wrong markup

The option "options.pageTree.showPathAboveMounts = 1" which shows the
rootline of each DB Mount in a line before is implemented in a
non-valid way.

This means, that a <div> tag is rendered within an <ul> tag right in
front of the <li> of the DB Mount node.

Change-Id: Ic715426b8d04220410bcb15bfba33a39e5fd47bc
Fixes: #31067
Releases: 4.6
Reviewed-on: http://review.typo3.org/5962
Reviewed-by: Xavier Perseguers
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe
Reviewed-by: Francois Suter
Tested-by: Francois Suter

History

#1 Updated by Mr. Hudson over 8 years ago

  • Status changed from New to Under Review

Patch set 1 of change Ic715426b8d04220410bcb15bfba33a39e5fd47bc has been pushed to the review server.
It is available at http://review.typo3.org/5962

#2 Updated by Mr. Hudson over 8 years ago

Patch set 2 of change Ic715426b8d04220410bcb15bfba33a39e5fd47bc has been pushed to the review server.
It is available at http://review.typo3.org/5962

#3 Updated by Steffen Ritter over 8 years ago

  • Status changed from Under Review to Resolved

#4 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF