Bug #31241

Fatal error on using non-existing code cache file

Added by Oliver Hader about 8 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Caching
Target version:
-
Start date:
2011-10-24
Due date:
% Done:

0%

TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

A fatal error will be thrown if the PHP code cache tries to require_once() a non-existing file. Thus it's checked whether the cache exists at all.

forge_31241.png View (322 KB) Oliver Hader, 2011-10-24 23:19

forge_31241.patch View (587 Bytes) Oliver Hader, 2011-10-24 23:42

History

#1 Updated by Oliver Hader about 8 years ago

  • Status changed from Accepted to Needs Feedback

Hm, there's already a file_exists() check...
The problem happened on uninstalling "fluid" in the extension manager and the fatal error of not having found the typo3temp/Cache/ file... strange...

#2 Updated by Christian Kuhn about 8 years ago

Hmm, there is code in em that deletes the cache file if an extension is loaded, and then re-instantiates the autoloader. Maybe something similar is needed for unloading an extension as well ...

#3 Updated by Christian Kuhn about 8 years ago

Unable to reproduce: I can unload fluid without fatal.

#4 Updated by Oliver Hader about 8 years ago

See screenshot - however not reproducible - sometimes it just happens...
Maybe a clearstatcache() helps here...

#5 Updated by Oliver Hader about 8 years ago

#6 Updated by Chris topher about 8 years ago

  • Target version changed from 4.6.0 to 4.6.1

#7 Updated by Chris topher about 8 years ago

  • Target version changed from 4.6.1 to 4.6.2

#8 Updated by Xavier Perseguers almost 8 years ago

  • Target version deleted (4.6.2)

#9 Updated by Alexander Opitz over 6 years ago

Hi Oliver,

what is the state of this issue?

#10 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Oliver Hader)
  • Is Regression set to No

No feedback for over 90 days.

If you think, that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation.

Also available in: Atom PDF