Bug #32030

Pagebrowser wrong result count

Added by Christian Sonntag almost 8 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2011-11-23
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The pagebrowser has a wrong behaviour on the result page.

For example results page 1:
0-20 of 150

For example results page 2:
21-40 of 145 <=?

For example results page 3:
41-60 of 142 <=?

Is it a configuration bug or a bug in the extension?


Related issues

Related to TYPO3 Core - Task #85117: Related to #32030 change from search to settings Closed 2018-05-30

Associated revisions

Revision 26eb262e (diff)
Added by Harry Glatz over 1 year ago

[BUGFIX] Fix indexed search TypoScript settings documentation

Releases: master, 8.7
Resolves: #85117
Related: #32030
Change-Id: I6af62c8337865e8a76c2dd8593f5afa38e0c2d26
Reviewed-on: https://review.typo3.org/57089
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Tested-by: TYPO3com <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 507dbb53 (diff)
Added by Tymoteusz Motylewski over 1 year ago

[BUGFIX] Fix indexed search TypoScript settings documentation

Releases: master, 8.7
Resolves: #85117
Related: #32030
Change-Id: I6af62c8337865e8a76c2dd8593f5afa38e0c2d26
Reviewed-on: https://review.typo3.org/57098
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

History

#1 Updated by Florian Scholz over 6 years ago

This may help ...

plugin.tx_indexedsearch {
search {
exactCount = 1
}
}

#2 Updated by Oliver Hader over 6 years ago

  • Target version set to 2222

#3 Updated by Oliver Hader over 6 years ago

  • Project changed from Indexed Search to TYPO3 Core

#4 Updated by Oliver Hader over 6 years ago

  • Category set to Indexed Search

#5 Updated by Oliver Hader over 6 years ago

  • Target version deleted (2222)

#6 Updated by Michael Stucki over 6 years ago

  • Status changed from New to Accepted
  • TYPO3 Version set to 6.0

Just got informed about the same issue last week. Afaik it only occurs while exactCount is turned on.

#7 Updated by Christian Drath about 6 years ago

I can confirm this issue in 4.5.17 and 4.5.27. The configuration mentioned in #1 solved the problem in both cases.

#8 Updated by Mathias Schreiber over 4 years ago

  • Status changed from Accepted to Closed
  • Is Regression set to No

#9 Updated by Manuel Bachl about 2 years ago

  • TYPO3 Version changed from 6.0 to 8
  • PHP Version set to 7.0

Issue is still present in TYPO3 8.7.4

the possible worakround mentioned in #1 doesn't work. Tried setting the setting to 0 and 1.

#10 Updated by Tommaso Liberio about 2 years ago

i am running in the same issue.

solved the problem by using following TS:

plugin.tx_indexedsearch {
settings{
exactCount = 1
}
}

And not as #1

plugin.tx_indexedsearch {
search{
exactCount = 1
}
}

#11 Updated by Michael Stucki about 2 years ago

Hey everyone,

it's 4 years ago since I replied here last time, so I can't remember why I didn't mention the obvious thing:
It's a known issue that the count gets more precise with every additional result that has been checked.

For example, if a result contains your search words, but it is on a page which is not accessible for you, then it is counted until TYPO3 really checks the record.
By default, the counting stops when TYPO3 has collected all items to show for you. For example, when you're on page 1 of a 15 page result list, then results 11-150 will not be checked. While you click through the pagebrowser, more results will be checked, and the result count may become smaller with each page.

Like I said, that is a known behaviour (even Google handles result counting in a similar way). If you don't like it, then you can turn on the exact count feature (always check all results) at the cost of your performance...

I suggest to close the issue.

#12 Updated by Michael Stucki about 2 years ago

Oh and btw. I think Tommaso has a point about the property name.

The real issue here seems to be that it is documented wrong, see https://docs.typo3.org/typo3cms/extensions/indexed_search/Configuration/TypoScript/Index.html?highlight=exactcount

#13 Updated by Tommaso Liberio about 2 years ago

i just checked the template analyzer to get the right property. But i think they should change it in the documentation.

#14 Updated by Tymoteusz Motylewski over 1 year ago

  • Related to Task #85117: Related to #32030 change from search to settings added

#15 Updated by Tymoteusz Motylewski over 1 year ago

fixed in #85117

Also available in: Atom PDF