Bug #32374

MENU special = updated not working in 4.6

Added by sven waechli over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
Start date:
2011-12-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

MENU special = updated is not working in TYPO3 Version 4.6.1

Following code worked with Version 4.5:

page.20.marks.LASTUPDATE.25 = HMENU
page.20.marks.LASTUPDATE.25 {
    special = updated
    special {
        value = 1
        depth = 3
        maxAge = 3600*24*90
        limit = 5
    }

    1 = TMENU
    1 {
        NO = 1
        NO.wrapItemAndSub = <li>|</li>
    }
}

Files


Related issues

Related to TYPO3 Core - Bug #31209: CONTENT still can't select records from rootpageClosed2011-10-24

Actions
Has duplicate TYPO3 Core - Bug #33220: Empty content object when select.pidInList=0 set in TSClosed2012-01-16

Actions
#1

Updated by Markus Klein over 10 years ago

Hi Sven!

What does it show now? Nothing or too much, wrong data?

Regards Markus

#2

Updated by sven waechli over 10 years ago

Hi Markus
The menu behaves as if there were no updated pages. That means zero output. I reproduced the problem locally with the TYPO3 MAMP Installer Version 4.5.3 and 4.6.1. The installed testsite already contains lastupdated Typoscript Code that just needs to be activated. Result: 4.5.3 works (menu is generated), 4.6.1 is not working (no menu is generated). A screenshot of how it should work is attached.

Kind regards,
Sven

#3

Updated by Henrik Ziegenhain over 10 years ago

I can confirm it as a bug.
My lastUpdated menu stopped working with 4.6 - I output the 9 last updated pages.

Now the pages seems to be unordered and selected wrong.

#4

Updated by Ingo Pfennigstorf over 10 years ago

I can confirm this, too - TYPO3 4.6.3

#5

Updated by Xavier Perseguers over 10 years ago

  • Status changed from New to Accepted
#6

Updated by Xavier Perseguers over 10 years ago

  • Assignee set to Xavier Perseguers

OK, I trapped the bug! Now have to figure out how to deal with it

#7

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7739

#8

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7839

#9

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Under Review to Resolved
  • Target version set to 4.6.4
#10

Updated by Xavier Perseguers over 10 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF