Bug #32626

not equal statement only works with != not with <>

Added by Joerg Kienast almost 8 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2011-12-16
Due date:
% Done:

100%

TYPO3 Version:
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

according to this bug report
http://bugs.typo3.org/view.php?id=18374#c61447

It looks like the DBAL Parser cannot handle <> in the WHERE clause if I use != it works fine.

if <> is standard SQL I think this should be added to the SQL Parser of DBAL.


Related issues

Related to TYPO3 Core - Bug #32161: Invalid SQL in the indexed_search Closed 2011-11-29

Associated revisions

Revision dd21e4fb (diff)
Added by Stefan Neufeind almost 8 years ago

[BUGFIX] Add SQL-comparator <> to SQL parser

Comparator != was supported before.
But <> is ANSI SQL and therefore should be
supported as well.

Change-Id: I49dde6f06715ecd33df044d8a2e85a813516d6ad
Fixes: #32626
Releases: 4.4, 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/7325
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

Revision d0a10f22 (diff)
Added by Stefan Neufeind almost 8 years ago

[BUGFIX] Add SQL-comparator <> to SQL parser

Comparator != was supported before.
But <> is ANSI SQL and therefore should be
supported as well.

Change-Id: I49dde6f06715ecd33df044d8a2e85a813516d6ad
Fixes: #32626
Releases: 4.4, 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/7416
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

Revision f8d4623a (diff)
Added by Stefan Neufeind almost 8 years ago

[BUGFIX] Add SQL-comparator <> to SQL parser

Comparator != was supported before.
But <> is ANSI SQL and therefore should be
supported as well.

Change-Id: I49dde6f06715ecd33df044d8a2e85a813516d6ad
Fixes: #32626
Releases: 4.4, 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/7417
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

Revision 4f53d36d (diff)
Added by Xavier Perseguers almost 8 years ago

[BUGFIX] Add SQL-comparator <> to SQL parser

Comparator != was supported before.
But <> is ANSI SQL and therefore should be
supported as well.

Change-Id: I56e86bfda550036e31d5bec4e8430c47ff0b9b56
Fixes: #32626
Releases: 4.4, 4.5, 4.6, 4.7
Reviewed-on: http://review.typo3.org/7418
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

History

#1 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7325

#2 Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7325

#3 Updated by Stefan Neufeind almost 8 years ago

this would need to become "under review". (afaik doesn't happen automatically for the dbal-subproject; fix in core though ...)

I expect it would fix the DBAL-issue here, since DBAL extends from the t3lib-sqlparser, but unfortunately currently can't test against DBAL.

#4 Updated by Xavier Perseguers almost 8 years ago

  • Status changed from New to Under Review

#5 Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7325

#6 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7416

#7 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/7417

#8 Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_4-4 has been pushed to the review server.
It is available at http://review.typo3.org/7418

#9 Updated by Xavier Perseguers almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Michael Stucki about 6 years ago

  • Project changed from DBAL to TYPO3 Core

#11 Updated by Michael Stucki about 6 years ago

  • Category set to 999

#12 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF