Project

General

Profile

Actions

Bug #32686

closed

Restricting backend login to adminOnly disables switching backend users

Added by Anonymous about 12 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2011-12-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When setting

[BE][adminOnly] = 1

it's not possible to switch users to a non-admin account anymore.

i think that should be possible for testing purposes during the maintenance process.


Files

patch.txt (749 Bytes) patch.txt Patch Anonymous, 2011-12-19 12:25

Related issues 1 (0 open1 closed)

Has duplicate TYPO3 Core - Bug #24074: Switching to a non-admin BE user in adminOnly mode causes dead endClosed2010-11-16

Actions
Actions #1

Updated by Anonymous about 12 years ago

Actions #2

Updated by Oliver Hader about 12 years ago

  • Category set to Backend User Interface
  • Status changed from New to Accepted
  • PHP Version set to 5.2

You can change that directly by your contribution. Get more information here: http://typo3.org/development/bug-fixing/resolving-bugs/
So since you already have a patch available, you might consider putting that to review.typo3.org

Actions #3

Updated by Gerrit Code Review about 12 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7469

Actions #4

Updated by Gerrit Code Review about 12 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7469

Actions #5

Updated by Gerrit Code Review about 12 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7469

Actions #6

Updated by Gerrit Code Review about 12 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7469

Actions #7

Updated by Anonymous about 12 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #8

Updated by Gerrit Code Review over 11 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/13011

Actions #9

Updated by Gerrit Code Review over 11 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/13012

Actions #10

Updated by Anonymous over 11 years ago

  • Status changed from Under Review to Resolved
Actions #11

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF