Bug #32693

mod.web_list.hideTranslation also hides pages_language_overlay

Added by Stefan Geith almost 10 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-12-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

mod.web_list.hideTranslation = *
also hides pages_language_overlay, which should always be visible (if not restricted by access-rights)

Target: 4.6, 4.7
Related to: http://forge.typo3.org/issues/23198


Related issues

Related to TYPO3 Core - Feature #23198: Its not possible to hide translated records from listviewClosedSteffen Gebert2010-07-15

Actions
#1

Updated by Gerrit Code Review almost 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7387

#2

Updated by Markus Klein almost 10 years ago

Can you please describe in more detail what the issue is about? What is blocked by the non-visible pages_language_overlay table?

#3

Updated by Stefan Geith almost 10 years ago

TSconfig mod.web_list.hideTranslation = * hides all translated Records from the normal Web/List-View. With Checkbox "Localisation View" checked, the translations re-appear.

BUT: the table pages_language_overlay should not be hidden by this setting, because then these records will never show up (even with "Localisation View" checked); this is, because pages_language_overlay records never apear with sys_language_uid=0
AND: I think, table pages_language_overlay is a special case and they should be listed always.

#4

Updated by Gerrit Code Review almost 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7387

#5

Updated by Oliver Hader almost 10 years ago

  • TYPO3 Version changed from 4.7 to 4.6
#6

Updated by Oliver Hader almost 10 years ago

  • Complexity set to easy
#7

Updated by Gerrit Code Review over 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/7387

#8

Updated by Gerrit Code Review over 9 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/8919

#9

Updated by Stefan Geith over 9 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#10

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF