Bug #32780

Errors when hiding/unhiding and moving content

Added by Bart Dubelaar over 10 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2011-12-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

See bug #20598. Please reopen that one.


Related issues

Follows TYPO3 Core - Bug #20598: Error after hide/show elementClosed2009-06-08

Actions
#1

Updated by Steffen Gebert over 10 years ago

Dear Bart,

as the previous issue has been set to fixed after commits have been made, I prefer to handle this within a new issue.

Report was:

1: Could not be edited in offline workspace in the branch where found (failure state: 'Online record was not in versionized branch!'). Auto-creation of version not allowed in workspace!

when I use hide/show button in list mode.

Who else can still reproduce it?

#2

Updated by Cristian Eliade Moga over 10 years ago

This does not happen when I edit an element, but I get the following error when I try to change the order of the elements even if the table's versioning IS activated:

1: [newlog()] Move attempt failed due to workspace restrictions: Record could not be edited in workspace: Online record was not in versionized branch! // Could not insert record from table "table_name" in destination PID "11"

The elements' order remains unchanged, both on offline and live, after this action. It doesn't matter if I'm admin or non-admin user.

Tested on:
TYPO3 4.6.1 and 4.5.2
PHP 5.3.8
Apache 2.2.21 (Unix)

The site was built on TYPO3 4.4 then we switched to 4.5 then to 4.6

#3

Updated by Bart Dubelaar over 10 years ago

To clarify, I mean the hide/unhide button in the top bar. Not the one in the record list itself, that one was fixed some time ago. And for the moving of content, I do not mean the up down arrows, but the re-position button.

Everyone should be able to reproduce it as the problem is hardcoded in TCEmain and is still present in the current master on git. The question is how to fix it. Fixing TCEmain, or fixing the calls to TCEmain (which was the way in which previous occurrences of this bug were fixed). I believe TCEmain should be changed.

#4

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8688

#5

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8721

#6

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/8688

#7

Updated by Gerrit Code Review over 10 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8721

#8

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8721

#9

Updated by Gerrit Code Review over 10 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/8721

#10

Updated by Bart Dubelaar over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#11

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9585

#12

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9586

#13

Updated by Bart Dubelaar over 10 years ago

  • Status changed from Under Review to Resolved
#14

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9586

#15

Updated by Bart Dubelaar over 10 years ago

  • Status changed from Under Review to Resolved
#16

Updated by Michael Stucki over 8 years ago

  • Category changed from Bugs to Workspaces
#17

Updated by Michael Stucki over 8 years ago

  • Project changed from 624 to TYPO3 Core
  • Category changed from Workspaces to Workspaces
#18

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF