Bug #33089

Media element don't recognize new youtube links

Added by Robert Heel over 10 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-01-10
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

New youtube links build like
http://youtu.be/xxxxxxx

I've add a content provider and changed the regex.


Files

media_youtube.diff (1.03 KB) media_youtube.diff Robert Heel, 2012-01-10 13:16
#1

Updated by Markus Klein over 10 years ago

Hi Robert!

Would you mind pushing this patch to our review system?

Thanks, Markus

#2

Updated by Gerrit Code Review over 10 years ago

  • Status changed from New to Under Review

Patch set 2 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7828

#3

Updated by Steffen Gebert over 10 years ago

  • Priority changed from Must have to Should have

Okay.. the patch for 4.6 is fine,.

With 4.7 I'm unable to insert YouTube videos at all.

The one left is 4.5. Robert, do you have a clue, why it doesn't work there? Applying the patch fails only because of a whitespace change (else if to elseif). After merging this, the player doesn't show a video. Could you have a look, please? As it's LTS, it would be nice to have this included there, too.

Thanks a lot for your contribution!

#4

Updated by Robert Heel over 10 years ago

Hi Steffen, thanks for updating the patch!

Patch works fine with 4.5 here (after whitespace change)

#5

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch master has been pushed to the review server. It is available at http://review.typo3.org/8715

Sorry.. human error

#6

Updated by Gerrit Code Review over 10 years ago

Patch set 3 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/7828

#7

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/9406

#8

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9407

#9

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9408

#10

Updated by Anonymous over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 30 to 100
#11

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF