Bug #34581

Methods should not be private

Added by Francois Suter over 10 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Linkvalidator
Target version:
Start date:
2012-03-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Class tx_linkvalidator_Processor contains 2 private methods. This should be avoided at all costs, since it prevents useful XCLASSing. You would need very good reasons to make methods private. They should be protected instead. CGL reference: http://typo3.org/documentation/document-library/core-documentation/doc_core_cgl/4.5.1/view/1/3/

Was there a real reason for this decision or can it be changed?

#1

Updated by Philipp Gampe over 10 years ago

I guess there was no reason. I will change it.

#2

Updated by Philipp Gampe over 10 years ago

  • Status changed from New to Accepted
#3

Updated by Chris topher over 10 years ago

These private methods were introduced in #12649. The task was about splitting one method into several smaller methods, because the nesting would have been too deep otherwise. I can't remember there was a reason to make them private.

#4

Updated by Gerrit Code Review over 10 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9641

#5

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9744

#6

Updated by Gerrit Code Review over 10 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at http://review.typo3.org/9746

#7

Updated by Anonymous over 10 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:4626d810d28c76d4c401fb489df07b4de614e0c7.

#8

Updated by Michael Stucki over 8 years ago

  • Category set to Linkvalidator
#9

Updated by Michael Stucki over 8 years ago

  • Project changed from 1510 to TYPO3 Core
  • Category changed from Linkvalidator to Linkvalidator
#10

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF