Bug #34698

t3lib/class.t3lib_befunc.php -> getViewDomain

Added by Thomas Layh over 7 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-03-09
Due date:
% Done:

100%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The changed function getViewDomain should always take the firstDomain from the tree first instead of using the currently called backend domain.

I try to explain the problem with the following example tree.

- root1 (www.mydomain.com)
-- home
-- more pages
- root2 (www1.mydomain.com)

I login using the domain www1.mydomain.com. If I click on preview on the home page, I want to see the page www.mydomain.com/home.html. Currently, if a valid www1 domain is set, it is used instead of the domain in the root line. The behavior before (#30892) was that for the preview domain the rootline domain was used, now the www1 domain has a higher priority which is imho wrong.

Going to push the patch to gerrit.

class.t3lib_befunc.php.patch View (911 Bytes) Thomas Layh, 2012-03-09 18:20

Associated revisions

Revision 393179a3 (diff)
Added by Thomas Layh over 7 years ago

[BUGFIX] Resolving the correct preview domain

Since the patch #30892 the backend login domain has a higher priority
than the first domain in the rootline.

Changed this behavior to work like in the older TYPO3 version.

Change-Id: Ib6be760eb2707fb0fbf7b3b37464ba9ef9eab744
Fixes: #34698
Releases: 4.8, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/9519
Reviewed-by: Philipp Gampe
Reviewed-by: Tolleiv Nietsch
Tested-by: Tolleiv Nietsch
Reviewed-by: Georg Ringer
Tested-by: Georg Ringer
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers
Reviewed-by: Wouter Wolters

Revision a445a232 (diff)
Added by Thomas Layh over 7 years ago

[BUGFIX] Resolving the correct preview domain

Since the patch #30892 the backend login domain has a higher priority
than the first domain in the rootline.

Changed this behavior to work like in the older TYPO3 version.

Change-Id: Ib6be760eb2707fb0fbf7b3b37464ba9ef9eab744
Fixes: #34698
Releases: 4.8, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/9539
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers

Revision 601b575d (diff)
Added by Thomas Layh over 7 years ago

[BUGFIX] Resolving the correct preview domain

Since the patch #30892 the backend login domain has a higher priority
than the first domain in the rootline.

Changed this behavior to work like in the older TYPO3 version.

Change-Id: Ib6be760eb2707fb0fbf7b3b37464ba9ef9eab744
Fixes: #34698
Releases: 4.8, 4.7, 4.6, 4.5
Reviewed-on: http://review.typo3.org/9538
Reviewed-by: Xavier Perseguers
Tested-by: Xavier Perseguers
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter

History

#1 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/9519

#2 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/9538

#3 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_4-6 has been pushed to the review server.
It is available at http://review.typo3.org/9539

#4 Updated by Thomas Layh over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Robert Heel over 7 years ago

The preview domain has to be the same domain as the backend login, otherwise disabled pages or pages in workspace wouldn't be shown, because the BE cookie only exists in domain from backend login.

#6 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF