Bug #35244

TCAtree inline record triggers

Added by Philipp Gampe over 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-03-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

PHP Warning: Missing argument 2 for extDirect_DataProvider_BackendUserSettings::addToList() 
in /home/phil/t3-playground/t3-git/t3lib/extjs/dataprovider/class.extdirect_dataprovider_beusersettings.php line 107

This happens if I try to save a content element with a inline relation from the test extension from #27957.

The reason is that the function processRpc in class.t3lib_extjs_extdirectrouter.php does

return call_user_func_array(
            array($endpointObject, $singleRequest->method),
            is_array($singleRequest->data) ? $singleRequest->data : array()
        );
is called with $singleRequest->data being just array(0 => 'tcaTrees.731c5105a19f1cd75f62dd10f39355b1').

I'll attach the raw json data.


Files

raw-data.json (18.5 KB) raw-data.json Philipp Gampe, 2012-03-26 18:48

Related issues

Related to TYPO3 Core - Bug #27957: TCA tree somehow causes fatal error when using in inline record (IRRE)ClosedXavier Perseguers2011-07-07

Actions
#1

Updated by Philipp Gampe over 9 years ago

The json file actually contains three parameters for data.

#2

Updated by Philipp Gampe over 9 years ago

Ok, some more info, maybe it helps.

The exception happens at $index = 111 which would be this entry:

{"action":"ExtDirect","method":"addToList","data":["tcaTrees.731c5105a19f1cd75f62dd10f39355b1",0,"4f512819cab1c83f0747fa5a12c50996a64133a8"],"type":"rpc","tid":3070}

Notice that there are no quotes around the second parameter of the data array. In all other lines, quotes do exist.

Also the last line is only

{"action":"ExtDirect","method":"addToList","data":["tcaTrees.731c5105a19f1cd75f62dd10f39355b1","4f512819cab1c83f0747fa5a12c50996a64133a8"],"type":"rpc","tid":3071}

Here the second parameter is missing it all.

#4

Updated by Philipp Gampe about 9 years ago

I guess.

#5

Updated by Mathias Schreiber almost 7 years ago

  • Status changed from New to Closed
  • Is Regression set to No

seems to be a duplicate

Also available in: Atom PDF