Project

General

Profile

Actions

Bug #37158

closed

Missing labels for backend_layout and backend_layout_next_level

Added by Stephan Gruber about 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-05-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The labels are missing in the listview due to different identifiers in TCA and the language files.

tbl_pages.php

'label' => 'LLL:EXT:cms/locallang_tca.xml:pages.backend_layout'
'label' => 'LLL:EXT:cms/locallang_tca.xml:pages.backend_layout_next_level'

locallang_tca.xml (Version 4.5)

<label index="pages.backend_layout_formlabel">Backend Layout (this page only)</label>
<label index="pages.backend_layout_next_level_formlabel">Backend Layout (subpages of this page)</label>

locallang_tca.xlf (Version >= 4.6 )

<trans-unit id="pages.backend_layout_formlabel" xml:space="preserve">
<source>Backend Layout (this page only)</source>
</trans-unit>
<trans-unit id="pages.backend_layout_next_level_formlabel" xml:space="preserve">
<source>Backend Layout (subpages of this page)</source>
</trans-unit>

Actions

Also available in: Atom PDF