Bug #37349

Layout change modifies email output

Added by Mark Kuiphuis about 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2012-05-21
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.6
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

If the layout is changed for radio buttons, but possibly also for other field types, the output in the email shows an empty <input type="text" /> instead of the value which has been either selected (radio) or typed in).

When the Content-Type of the e-mail is text/plain, all information is shown correctly
When the Content-Type of the e-mail is text/html, the values are not shown anymore, but instead an input field is shown.


Files

input.png (16.1 KB) input.png The form in the fronted Mark Kuiphuis, 2012-05-21 02:49
email.png (14.6 KB) email.png The generated email Mark Kuiphuis, 2012-05-21 02:49
generated-html.png (17 KB) generated-html.png The generated HTML code of the email Mark Kuiphuis, 2012-05-21 02:49

Related issues

Related to TYPO3 Core - Bug #39138: sysEXT:form checkbox send as input field in EMailClosedPatrick Broens2012-07-20

Actions
Related to TYPO3 Core - Bug #31951: Own checkbox layout breaks HTML mailClosed2011-11-20

Actions
Related to TYPO3 Core - Bug #32463: New Form ext throws error on missing wrapsClosed2011-12-12

Actions
Related to TYPO3 Core - Bug #58598: tx_form breaks on custom labelClosed2014-05-07

Actions
#1

Updated by Michael Bakonyi almost 10 years ago

I think in general the layout of the mail should be independent of the form-layout. Currently both layouts are bind together so that it is nearly impossible to change the form-layout without breaking the mail-layout (html at least).

#2

Updated by Leon de Rijke over 8 years ago

Possibly a duplicate of #31951.

#3

Updated by Frans Saris over 7 years ago

  • Status changed from New to Resolved
  • Is Regression set to No
#4

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF