Bug #37812

Admin has no rights to update a file

Added by Stefan Froemken almost 9 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2012-06-07
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I just have installed TYPO3 6.0 for testing FAL. There are no problems with creating files and folders but I can't modify the files content. I don't have permissions to edit this file.
I have searched a very long time because FAL is pretty hugh. I found out that you define some default permissions for BE-Users. It's an Array containing an element called "editFile", but it will be checked against "updateFile". So please update your code to "editFile", or change the element within the array to "updateFile".

For now I have added following line to BE-Userrecords TSconfig:

permissions.file.storage.1.updateFile = 1

It doesn't work, because the returning value of getTSconfig is an Array containing always to elements "value" and "properties". This is what you do:

$storageFilePermissions = $this->getTSConfig('permissions.file.storage.' . $storageObject->getUid());

it should be:

$tsConfigPath = $this->getTSConfig('permissions.file.storage.' . $storageObject->getUid());
$storageFilePermissions = $tsConfigPath['properties'];

Now the both arrays are merged correctly.

Stefan


Related issues

Has duplicate TYPO3 Core - Bug #39860: Not possible to save edited files in fileadmin (TYPO3 6.0 Alpha3)ClosedAndreas Wolf2012-08-16

Actions
Has duplicate TYPO3 Core - Bug #39949: Local file not editable (as admin) - User right 'edit' vs. 'update'ClosedAndreas Wolf2012-08-19

Actions
#1

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14257

#2

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14257

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14257

#4

Updated by Steffen Ritter over 8 years ago

  • Target version changed from 6.0.0-alpha2 to 6.0.0-beta2
#5

Updated by Steffen Ritter over 8 years ago

  • Assignee set to Andreas Wolf
#6

Updated by Gerrit Code Review over 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14257

#7

Updated by Anonymous over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF