Project

General

Profile

Actions

Bug #37896

closed

Bug #46389: Faulty Workspace Placeholders

Live search in workspace shows move-to placeholders

Added by Bart Dubelaar about 12 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-06-11
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The live search foldout also lists placeholders for draft changes, clicking an item will open the placeholder itself for editing and not the draft version.


Files

placeholderresult.png (18 KB) placeholderresult.png Bart Dubelaar, 2012-08-08 10:15

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #36282: Live search result shows titles and icons of live elements when in draft workspaceClosed2012-04-18

Actions
Actions #1

Updated by Bart Dubelaar almost 12 years ago

The problem is slightly smaller in version 4.6 and up, as the patch for this issue http://forge.typo3.org/issues/31761 will confine searches for integers to the uid and pid field. However searching for the string 'placeholder' still reveals the placeholders.

Actions #2

Updated by Gerrit Code Review almost 12 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #3

Updated by Gerrit Code Review almost 12 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #4

Updated by Gerrit Code Review almost 12 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #5

Updated by Gerrit Code Review almost 12 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #6

Updated by Gerrit Code Review almost 12 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #7

Updated by Bart Dubelaar almost 12 years ago

How to reproduce:

In 4.5:
1. Create a new page in the live workspace and note the uid
2. Move the page to another location in a draft workspace
3. Stay in the draft workspace and search for the uid in the upper right search box
The live results will now show the page itself and the placeholder. See attached screenshot.

In 4.6 and up searching for integers is confined to the uid and pid field so the problem is less prominent.
However the problem still shows when searching for the word "placeholder":
1. Create a new page in the live workspace
2. Move the page to another location in a draft workspace
3. Stay in the draft workspace and search for the word "placeholder" in the upper right search box

Actions #8

Updated by Oliver Hader about 11 years ago

  • Parent task set to #46389
Actions #9

Updated by Gerrit Code Review over 10 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/13409

Actions #10

Updated by Gerrit Code Review over 10 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/13409

Actions #11

Updated by Gerrit Code Review over 9 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #12

Updated by Gerrit Code Review almost 9 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #13

Updated by Gerrit Code Review over 8 years ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/13409

Actions #14

Updated by Bart Dubelaar over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #15

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44925

Actions #16

Updated by Anonymous over 8 years ago

  • Status changed from Under Review to Resolved
Actions #17

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF