Bug #38387

Link Class Selection in RTE with IE 7, 8 and 9

Added by Manuel Thaler over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2012-06-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently Link-Class can not be set at the Backend RTE in Internet Explorerer 7, 8 and 9.

i.e. we intended to set a link as download-link, or opens in an external window and the value of the link class gets lost when chosing it. as soon as the focus returns to the rte in backend, the value ist not beeing passed through. In Firefox and Chrome this seems to work properly.

Please have an ey on this. it's an important feature for setting links.

Cheers


Related issues

Is duplicate of TYPO3 Core - Bug #38300: IE9 can not insert links any moreClosedStanislas Rolland2012-06-22

Actions
#1

Updated by Oliver Hader over 8 years ago

  • Status changed from New to Needs Feedback

Please be more specific. Does that work in other browsers, but not in Internet Explorer?
Can you please provide screenshots and/or your PageTSconfig settings?

#2

Updated by Oliver Hader over 8 years ago

Oh, and what TYPO3 version are you using?

#3

Updated by Manuel Thaler over 8 years ago

There we go: In IE 7 8 and 9 it's not possible to set a Link Class in RTE by selecting i.e. E-Mail-Link, internal Site-Link or any other type. (We've tried out this in a native IE in Version 8 and 9, as well as in the F12-Debugmode in ie 9 for all the browsers and in IE-Tester on Windows)

To reproduce:
Go to TYPO3 Backend, chose an existing Site and add or edit a default Text or Text with Image content.
Set a Link and push open the Link-Settings-Button. Then enter any type of link - let's take an E-Mail link. Under Style (Stil in German) you can select the suggested "E-Mail-Link" and press "Set Link (DE: Link setzen)".

The popup window closes and the focus turns back to the RTE-Field. The strange thing about it: in Internet-Explorer, the Link-Class is not beeing applied.

Is there any Workaround for this behaviour?

In Google Chrome, Firefox, this seems to work pretty well.

Thank you for having an eye on it.

By the way: I am using 4.7.1, Gov-Pack

#4

Updated by Oliver Hader over 8 years ago

  • Project changed from Accessibility Project to TYPO3 Core
#5

Updated by Oliver Hader over 8 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
  • PHP Version set to 5.3
  • TYPO3 Version set to 4.7
#6

Updated by Oliver Hader over 8 years ago

  • Status changed from Needs Feedback to Closed

Closed - It's a duplicate of issue #38300

Also available in: Atom PDF