Bug #38607

Remove t3ver_swapmode code blocks

Added by Oliver Hader over 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Workspaces
Target version:
Start date:
2012-07-03
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.


Related issues

Related to TYPO3 Core - Bug #38063: Content elements disappear on publishing a page Closed 2012-06-15
Related to TYPO3 Core - Bug #38608: Remove t3ver_swapmode code blocks Closed 2012-07-03

Associated revisions

Revision 9a7f866b (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Remove t3ver_swapmode code blocks

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.

Change-Id: Iced3f3ee35165f43040d878ee24fea0fe63a3a31
Fixes: #38607
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12554
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

Revision e2de1a3c (diff)
Added by Oliver Hader over 7 years ago

[BUGFIX] Remove t3ver_swapmode code blocks

The different ways of versioning (element, page, branch) have
been defined to element versioning some TYPO3 version ago. With
TYPO3 4.7, those settings, especially the handling of the field
t3ver_swapmode has been removed from t3lib_TCEmain.

Since the default value of t3ver_swapmode is not -1 anymore,
but 0 instead, this will lead to inconsistent side-effects.

The solution is to remove all occurrences.

Change-Id: If5100ab639a4412effa7dbc76737fa042123ffa8
Fixes: #38607
Releases: 6.0, 4.7
Reviewed-on: http://review.typo3.org/12552
Reviewed-by: Oliver Hader
Tested-by: Oliver Hader

History

#1 Updated by Oliver Hader over 7 years ago

  • Assignee set to Oliver Hader

#2 Updated by Oliver Hader over 7 years ago

  • Tracker changed from Task to Bug

#3 Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch workspaces_4-7 has been pushed to the review server.
It is available at http://review.typo3.org/12552

#4 Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/12554

#5 Updated by Oliver Hader over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:681f8410577cd69dd9110897f84d8f8fe0eab8cf.

#6 Updated by Michael Stucki almost 6 years ago

  • Category changed from Code Cleanup to Workspaces

#7 Updated by Michael Stucki almost 6 years ago

  • Project changed from Workspaces & Versioning to TYPO3 Core
  • Category changed from Workspaces to Workspaces

#8 Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF