Task #39115

Wrong description in t3lib_extMgm::siteRelPath

Added by Stefan Froemken almost 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Documentation
Target version:
Start date:
2012-07-20
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
5.3
Tags:
Complexity:
easy
Sprint Focus:

Description

Hello TYPO3-Team,

this is not a bug. This is a hint regarding a wrong description of the method siteRelPath in t3lib_extMgm.

You wrote: "Useful for images and links from the frontend"

THIS IS WRONG!
siteRelPath does not respect config.absRelPrefix. And that is good. Don't change that! But please change the confusing description of that method to something like that:

"Useful for images and links from the backend"
or
"Only useful for internal processes within your extension."

Maybe you can add a hint HOW to use siteRelPath within the FE:
"If you need a valid path for your FE, then insert the result of this method into $this->cObj->fileResource($path)"

Stefan

Also available in: Atom PDF