Project

General

Profile

Actions

Bug #39248

closed

fetchUserRecord don't work without username

Added by Robert Heel almost 12 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-07-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

e.g. fetchUserRecord($dbUser, false, 'fe_users.uid=1') don't work because $usernameClause is empty and is followed by " AND" in the sql query.

It should be set to "1=1", or $extraWhere should moved after $usernameClause.

Patch attached.


Files

fetchUserRecord_wo_username.diff (717 Bytes) fetchUserRecord_wo_username.diff Robert Heel, 2012-07-25 13:20
Actions

Also available in: Atom PDF