Bug #39549

"translation handling" fails with Ext. version

Added by Paul Keller over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Must have
Category:
Localization
Target version:
Start date:
2012-08-03
Due date:
% Done:

0%

TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

As soon as we install the Extension "version" (Versioning Management) on any TYPO3 installation and try to fetch the language translation for all Extension, the following error appears as soon as the translation handling reaches the Ext. "version":
Fatal error: Cannot use string offset as an array in /data/webs/125/12562/public_html/typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php on line 1244

As soon as we deinstall "workspaces" an "version" the translationing handling works fine.


Related issues

Related to TYPO3 Core - Bug #39637: Fatal error: Cannot use string offset as an array in /home/user/public_html/ordner/typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php on line 1300 Closed 2012-08-09
Duplicates TYPO3 Core - Bug #40108: PHP warning when no language pack is available Closed 2012-08-24

History

#1 Updated by Jeff Segars over 7 years ago

  • Status changed from New to Needs Feedback

Paul,
I've got a couple questions to try to isolate the issue.

1. Does the problem still occur if you change your Extension Manager settings to no longer use a mirror but instead use the TYPO3.org Main Repository?
2. Does the problem occur for one specific language or all languages?
3. Does the problem occur when checking translation status or only when updating translations?
4. Does the problem occur using both the old and new user interfaces for the Extension Manager? Based on the file mentioned in your original description, it sounds like you're using the new user interface.
5. Does the problem still occur if you manually delete the lang-l10n-* zip file in typo3temp?

Thanks!
Jeff

#2 Updated by Paul Keller over 7 years ago

Hi Jeff

The translation handling suddenly works fine again. I assume it must have been a problem with the language files of the Ext. "version" on the remote server.

Anyway here the answers to your questions:
1. Problem occured with connection to TYPO3.org mirror as well.
2. Alle languages
3. Problem with checking and updating
4. Problem with new and old interface
5. I did not check this, sorry.

I guess we can close this bug. If the Problem should appear again. I'll get back to you.

#3 Updated by Arno Dudek over 7 years ago

Get also this error:

Fatal error: Cannot use string offset as an array in typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php on line 1289

It happens always between "filelist" and "fluid" at language update. At "fluid" it freeze.
Tried with the repositories of typo3.org and ter.mittwald.de.

TYPO3 v6.0.0aplpha3

#4 Updated by Steffen Gebert about 7 years ago

  • Category set to Localization
  • Status changed from Needs Feedback to Closed
  • Assignee set to Steffen Gebert
  • Target version set to 4.5.20

Duplicate of #40108, which has already been fixed.

Also available in: Atom PDF