Bug #39637

Fatal error: Cannot use string offset as an array in /home/user/public_html/ordner/typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php on line 1300

Added by Michal Idziorek about 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Category:
Localization
Target version:
Start date:
2012-08-09
Due date:
% Done:

0%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I get this when try to check for updates in the extensions manager.

Fatal error: Cannot use string offset as an array in /home/user/public_html/ordner/typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php on line 1300

Following fix works for me:
...

$temp1=$fetch[$lang];
$temp2=$temp1["md5"];

if($localmd5!=$temp2){

...


Related issues

Related to TYPO3 Core - Bug #39549: "translation handling" fails with Ext. version Closed 2012-08-03
Duplicates TYPO3 Core - Bug #40108: PHP warning when no language pack is available Closed 2012-08-24

History

#1 Updated by Markus Klein about 7 years ago

Please check, if the main repository is selected in the settings tab.
There seem to be some issues with some mirrors currently.

#2 Updated by Jeff Segars about 7 years ago

  • Status changed from New to Needs Feedback

#3 Updated by Michal Idziorek about 7 years ago

yes, it is selected indeed!

I have changed

if($localmd5!==$fetch[$lang]['md5']){ ...

on line 1300 in typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php

to the lines already mentioned above:
$temp1=$fetch[$lang]; $temp2=$temp1["md5"]; if($localmd5!=$temp2){

and it works.

#4 Updated by Florian Carstens about 7 years ago

I got the same error while updating the language packages. Michal's fix also solved my problem.

#5 Updated by Mathias Bolt Lesniak about 7 years ago

I can confirm this from my end too. (TYPO3 4.7.4)

It is fetching the language for Fluid that stops the process.

Michal's fix works for me too.

#6 Updated by Gregor Hermens about 7 years ago

Same here with TYPO3 4.5.19 on line 1244.
Michal's fix helped, but please use !== instead of !=.
Now only the language update for fluid aborts, but the process continues with the next extension.

#7 Updated by Thomas Hilburger about 7 years ago

Got the same issue in 4.7.2 on line 1300 and translation update also stops at Fluid-ext.

Can't make the changes in the file because I have no access to the source files.

Any solution at the horizon? Can I skip the fluid-update somehow?

#8 Updated by Patrick Hafner almost 7 years ago

Same with TYPO3 4.5.19, Fluid 1.3.0 and main repository:
Fatal error: Cannot use string offset as an array in /var/www/websites/typo3/sysext/em/classes/connection/class.tx_em_connection_extdirectserver.php on line 1244

Michal's fix works, but fluid translation update fails

#9 Updated by Steffen Gebert almost 7 years ago

  • Category set to Localization
  • Status changed from Needs Feedback to Closed
  • Assignee set to Steffen Gebert
  • Target version set to 4.5.20

Duplicate of #40108, which has already been fixed.

#10 Updated by adam lord over 4 years ago

I can confirm this from my end too. (TYPO3 4.7.4)

It is fetching the language for Fluid that stops the process.

Michal's fix works for me too.

www.batidosverdesyzumos.com

Also available in: Atom PDF