Bug #40215

Task #40095: Move core to namespaces

Task Table garbage collection (scheduler) fails

Added by Philipp Gampe almost 9 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
scheduler
Target version:
-
Start date:
2012-08-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Execution failed: 1308354399, TYPO3\CMS\Scheduler\Scheduler_TableGarbageCollection misconfiguration: sys_log does not exist in configuration
#1

Updated by Christian Kuhn almost 9 years ago

  • Parent task set to #40095
#2

Updated by Gerrit Code Review almost 9 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14116

#3

Updated by Christian Kuhn almost 9 years ago

  • Project changed from TYPO3 Core to 739
#4

Updated by Christian Kuhn almost 9 years ago

Ah, since the array key is used as class name, the namespace change breaks b/w compatibility for registered tasks ... we need to think about this issue again.

#5

Updated by Philipp Gampe almost 9 years ago

As said on the change, we properly need some kind of upgrade wizard that converts the task objects (and the corresponding sys_registry entries).

I do not know if I have some time left next week to look into it, but I will definitely review any changes done here since I know the scheduler code to main part.

#6

Updated by Gerrit Code Review almost 9 years ago

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#7

Updated by Gerrit Code Review almost 9 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#8

Updated by Gerrit Code Review almost 9 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#9

Updated by Gerrit Code Review almost 9 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#10

Updated by Gerrit Code Review almost 9 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#11

Updated by Gerrit Code Review almost 9 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#12

Updated by Gerrit Code Review almost 9 years ago

Patch set 7 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#13

Updated by Gerrit Code Review over 8 years ago

Patch set 8 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#14

Updated by Gerrit Code Review over 8 years ago

Patch set 9 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14236

#15

Updated by Thomas Maroschik over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Michael Stucki over 7 years ago

  • Category set to scheduler
#17

Updated by Michael Stucki over 7 years ago

  • Project changed from 739 to TYPO3 Core
  • Category changed from scheduler to scheduler
#18

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF