Bug #40855

stdWrap of special.value in HMENU is applied twice

Added by Christian Zenker about 7 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
-
Start date:
2012-09-12
Due date:
% Done:

100%

TYPO3 Version:
4.7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Sprint Focus:

Description

also appears in 4.5 and very likely 4.6

If the stdWrap functionality of HMENU.special.value is used, this is applied twice.
I'm not very familiar on how HMENU works internally. If someone could tell me the best place to fix this without side-effects, I would be happy to submit a patch.

Here are my findings:

The first time stdWrap is applied is tslib_content_HierarchicalMenu::render() (line 59 in TYPO3 4.5.19).
Then it is added multiple times accross tslib_menu again.

I would go with removing the stdWrapping in tslib_menu, but am I right with this or is there any other entry point to this class other than tslib_content_HierarchicalMenu::render() that I should check?

Associated revisions

Revision 536857e3 (diff)
Added by Markus Klein over 6 years ago

[BUGFIX] stdWrap for special.value applied twice

In HMENU the stdWrap for special.value is applied twice.
This patches removes the superfluous call
in HierarchicalMenuContentObject.php.

Furthermore it also moves the stdWrap for excludeUidList
to AbstractMenuContentObject.php for consistency reasons.

Change-Id: Ia6594a76602acdab8b39d50803595343e65f6d02
Releases: 6.2, 6.1, 6.0, 4.7, 4.5
Fixes: #40855
Reviewed-on: https://review.typo3.org/14588
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

Revision aae657ce (diff)
Added by Markus Klein over 6 years ago

[BUGFIX] stdWrap for special.value applied twice

In HMENU the stdWrap for special.value is applied twice.
This patches removes the superfluous call
in HierarchicalMenuContentObject.php.

Furthermore it also moves the stdWrap for excludeUidList
to AbstractMenuContentObject.php for consistency reasons.

Change-Id: Ia6594a76602acdab8b39d50803595343e65f6d02
Releases: 6.2, 6.1, 6.0, 4.7, 4.5
Fixes: #40855
Reviewed-on: https://review.typo3.org/21687
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

Revision c3808a69 (diff)
Added by Markus Klein over 6 years ago

[BUGFIX] stdWrap for special.value applied twice

In HMENU the stdWrap for special.value is applied twice.
This patches removes the superfluous call
in HierarchicalMenuContentObject.php.

Furthermore it also moves the stdWrap for excludeUidList
to AbstractMenuContentObject.php for consistency reasons.

Change-Id: Ia6594a76602acdab8b39d50803595343e65f6d02
Releases: 6.2, 6.1, 6.0, 4.7, 4.5
Fixes: #40855
Reviewed-on: https://review.typo3.org/14588
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind
Reviewed-on: https://review.typo3.org/21686

Revision 7afc40aa (diff)
Added by Markus Klein over 6 years ago

[BUGFIX] stdWrap for special.value applied twice

In HMENU the stdWrap for special.value is applied twice.
This patches removes the superfluous call
in HierarchicalMenuContentObject.php.

Furthermore it also moves the stdWrap for excludeUidList
to AbstractMenuContentObject.php for consistency reasons.

Change-Id: Ia6594a76602acdab8b39d50803595343e65f6d02
Releases: 6.2, 6.1, 6.0, 4.7, 4.5
Fixes: #40855
Reviewed-on: https://review.typo3.org/21739
Reviewed-by: Wouter Wolters
Tested-by: Wouter Wolters
Reviewed-by: Stefan Neufeind
Tested-by: Stefan Neufeind

History

#1 Updated by Markus Klein about 7 years ago

Hi!

Looking at the whole code here, all I can say: This is a complete mess!

After thinking about it a lot, it is somewhat impossible to move all the stdWraps of HMENU to the place where they actually belong, namely tslib_content_HierarchicalMenu.
One major problem is the fallback mechanism of minItems and maxItems.

Hence, the only chance to get this fixed is to remove the stdWrap from tslib_content_HierarchicalMenu.
Also excludeUidList should be moved to the place where it is used, to get at least some kind of consistency.

The stdWraps in tslib_menu are there since Nov. 2007 by Bernhard Kraft, whereas tslib_content_HierarchicalMenu exists only since Oct. 2010.

#2 Updated by Jigal van Hemert about 7 years ago

  • Status changed from New to Accepted

#3 Updated by Gerrit Code Review about 7 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/14588

#4 Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14588

#5 Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14588

#6 Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/14588

#7 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21686

#8 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/21687

#9 Updated by Markus Klein over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Gerrit Code Review over 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_4-7 has been pushed to the review server.
It is available at https://review.typo3.org/21738

#11 Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_4-5 has been pushed to the review server.
It is available at https://review.typo3.org/21739

#12 Updated by Markus Klein over 6 years ago

  • Status changed from Under Review to Resolved

#13 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF