Bug #40865

Option to show secondary options (palettes) even though no options available

Added by Stefan Neufeind almost 9 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-09-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The checkbox "Show secondary options (palettes)" is usually available when editing a content-element. A user with limited rights might however have no fields which are currently hidden. But still he/she sees that checkbox - and sees no difference when setting/unsetting it.


Related issues

Related to TYPO3 Core - Feature #50481: TCEforms: Replace "More options" icon for uncollapsing palettesClosed2013-07-26

Actions
#1

Updated by Jigal van Hemert almost 9 years ago

  • Status changed from New to Needs Feedback

Do you propose to hide it if no secondary option are available? It is a permanent option and it is easy to set it even if no secondary options are visible on that page; at least you know that on other pages all options are visible.

Maybe we should move this to the usability team first?

#2

Updated by Stefan Neufeind almost 9 years ago

I was thinking whether we should display it at all in places where it has no use. Another option might be to grey it out. What real purpose does it serve if there are no secondary options (for a person with limited rights)?

The question came up when somebody discovered "oh, I don't have that checkbox set" who then went to set it and wondered what changed since he/she set it.

Maybe contacting the usability-team might be a good option, as suggested.

#3

Updated by Alexander Opitz almost 8 years ago

Created #50354 for UX Team

#4

Updated by Ernesto Baschny almost 8 years ago

Meanwhile it was decided in the UX discussion to split up the task into three topics. Refer to the discussion and outcome in #50354.

Please join the discussion or help in the implementation. First task already created: #50481.

End result will be that the Checkbox is removed altogether.

#5

Updated by Markus Klein almost 7 years ago

  • Status changed from Needs Feedback to Closed
  • Is Regression set to No

Last update was 1 year ago. closing

Also available in: Atom PDF