Bug #40867

Epic #90674: Backend UI not reflecting permissions

User-rights: Workspaces-settings though workspace-extension disabled

Added by Stefan Neufeind about 8 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2012-09-12
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Under rights for user/user-group (BE) there is a tab for "Mounts and workspaces". That even shows the ability to choose workspace-permissions when the workspace-extension is disabled.

By default the workspaces "Live" and "Draft" always "exist". But could those settings maybe only shown when the workspaces-modul is actually loaded? Or can those settings even be added to the mask dynamically by the workspace-extension itself (so it would not show unless that extension is loaded)?

Associated revisions

Revision 045e4a9c (diff)
Added by Benni Mack 7 months ago

[BUGFIX] Hide fields for backend users / groups if not enabled

The fields
  • be_groups.workspace_perms
  • be_users.workspace_perms
  • be_users.disableIPlock

Are now only shown if the requirements are met (e.g. EXT:workspaces
is installed, or the IPlock options are enabled

Resolves: #40867
Releases: master
Change-Id: Id6310bdbfbd187c2d0190118476a1b3fe729aa77
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63761
Tested-by: TYPO3com <>
Tested-by: Georg Ringer <>
Tested-by: Susanne Moog <>
Reviewed-by: Georg Ringer <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35987

#2 Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/35987

#3 Updated by Mathias Schreiber almost 6 years ago

  • Status changed from Under Review to New
  • Is Regression set to No

#4 Updated by Riccardo De Contardi about 5 years ago

as far as I can remember, the "draft" workspace has been removed since 4.5
It is true that, even if the workspaces extension is disabled, the user and usergroup record has still the "Workspace permissions: edit live (online)" checkbox on the tab "Mounts and workspaces", which may be a bit confusing if there are no workspaces (this still happens on 7.6-dev (latest master)).
I see 2 possible solutions:

1) hide the checkbox if ext:workspaces is disabled
or
2) make the checkbox disabled if ext:workspaces is disabled

#5 Updated by Stefan Neufeind about 5 years ago

Or have that checkbox added to the dialog by EXT:workspaces itself? Imho that would be the clean way to decouple that EXT. (I'm aware it's still hard-wired in some other areas - but we'll have to start somewhere.)
I somewhat doubt though that this change is likely to land in 7 - more realistic for 8 then.

#6 Updated by Riccardo De Contardi about 5 years ago

of course! I wrote it badly :) I should have written "remove" instead of "hide"

#7 Updated by Riccardo De Contardi 8 months ago

  • TYPO3 Version changed from 4.5 to 9

This issue is still present on 9.5.14

Test:

  1. Fresh TYPO3 installation without EXT:workspaces installed
  2. Create a BE usergroup
  3. "Tab Mounts and Workspaces" > the checkbox Workspace permissions [workspace_perms] is still present and the value is 0 by default

#8 Updated by Riccardo De Contardi 8 months ago

  • Parent task set to #90674

#9 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63761

#10 Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63761

#11 Updated by Benni Mack 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#12 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF