Bug #41050

core itself calls deprecated method deprecationLogForOldExtCacheSetting

Added by Simon Schaufelberger about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Could have
Assignee:
-
Category:
-
Target version:
-
Start date:
2012-09-18
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

see:
typo3\sysext\cms\tslib\index_ts.php

line 65

... and fills the deprecation log which the core itself should NOT do.

History

#1 Updated by Markus Klein about 7 years ago

Simon, are you sure this comes from deprecationLogForOldExtCacheSetting?
The method is @deprecated 6.0, but does not call \TYPO3\CMS\Core\Utility\GeneralUtility::logDeprecatedFunction(), hence there shouldn't be a message.

(I don't remember whether the @deprecated comment is now handled automatically or the logDeprecatedFunction() call is still necessary.)

#2 Updated by Oliver Hader about 7 years ago

  • Status changed from New to Needs Feedback
  • Priority changed from Must have to Could have

There's no automatic resolving of @deprecated annotations since this would require reflection on every method - the deprecation log has still to be called individually.

For the case Simon mentions, the $GLOBALS['TYPO3_CONF_VARS']['SYS']['extCache'] is defined which is considered as deprecated - thus, remove the setting in the Install Tool or typo3conf/LocalConfiguration.php directly.

#3 Updated by Markus Klein almost 7 years ago

Simon, what's the status here?

#4 Updated by Jigal van Hemert over 6 years ago

  • Status changed from Needs Feedback to Closed

Seems to be a configuration error; no feedback for over 90 days. Closed.

#5 Updated by Simon Schaufelberger over 6 years ago

ups, totally lost focus about that one. well i don't care about that and i guess the core is fixed already since the code is always changing.

Also available in: Atom PDF