Bug #41434

userTSconfig: TCAdefaults.tt_content.imagecols = 1 does not always work

Added by Stefan Neufeind over 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Category:
Miscellaneous
Target version:
Start date:
2012-09-27
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

As described in #16806 by Sacha Vorbeck (over 4 years ago!):
default-value for imagecols [...] "via User TSconfig is only taken into account when you create a new content element text and then switch it to image. If you create the content element via the new content element wizard and select an image directly, the value will always be 2."

Can reproduce this with 4.5.19. So unfortunately it's not yet solved.


Related issues

Related to TYPO3 Core - Bug #16806: TCAdefaults.tt_content.imagecols = 1 is missingClosedSteffen Kamper2006-12-22

Actions
Related to TYPO3 Core - Bug #22712: userTSconfig: TCAdefaults.tt_content.imagecols = 1 does not workClosed2010-05-25

Actions
Related to TYPO3 Core - Bug #63049: TCAdefaults imagecols doesn't workClosed2014-11-18

Actions
#1

Updated by Georg Schönweger over 8 years ago

Did you try mod.wizards?
mod.wizards.newContentElement.wizardItems.common.elements.textpic.tt_content_defValues.imagecols = 1

#2

Updated by Stefan Neufeind over 8 years ago

Yes, that way it works. To be exact:
mod.wizards.newContentElement.wizardItems.common.elements.image.tt_content_defValues.imagecols=1

Jigal just brought that up. The TCAdefault-value is overridden by the wizard-default here (which is 2). He's already discussing internally how to proceed about this (kind of) "inconsistency".

#3

Updated by Jigal van Hemert over 8 years ago

  • Category set to Documentation

The setting

mod.wizards.newContentElement.wizardItems.common.elements.image.tt_content_defValues.imagecols

overrides the settings from TCAdefaults because they are sent by the New Content Element Wizard to the new content element form through the defVals GET variable.

See http://typo3.org/documentation/document-library/core-documentation/doc_core_tsconfig/4.7.0/view/1/3/#id699154 for the priorities regarding the default values for fields.

The TSconfig documentation should contain a note about this setting which influences the defVals.

#4

Updated by Jigal van Hemert over 8 years ago

  • Category changed from Documentation to Miscellaneous
  • Status changed from New to Accepted
  • Assignee set to Jigal van Hemert
  • Target version set to 4.5.20
  • Complexity set to easy

Further testing showed that a better place for the wizard settings which are not different for various CE types is actually the TCA defaults in the default user settings.

#5

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/15118

#6

Updated by Jigal van Hemert over 8 years ago

How to test:

- TCAdefaults.tt_content.imagecols = 5 in user TSconfig
- make new CE with wizard of type "text"
- switch to type "image"
- on the Appearance tab the number of columns is 5

- make a new CE with wizard of type "image"
- on the Appearance tab the number of columns is 2

The 2 is set by mod.wizards.newContentElement.wizardItems.common.elements.image.tt_content_defValues.imagecols = 2 in pageTSconfig. This is used if you directly select the "image" CE type in the wizard. If you first select the "text" type imagecols is not set via defVals and the TCAdefaults setting is used.
Moving the imagecols=2 to the TCAdefaults for the default user TSconfig setting solves the problem without side effects (custom settings not working).

#7

Updated by Wladimir Hofmann over 8 years ago

same story in TYPO3 4.7.5

But as I use templavoila (v. 1.7.0), I tried in pageTSconfig:

templavoila.wizards.newContentElement.wizardItems.common.elements.textpic.tt_content_defValues.imagecols=1
templavoila.wizards.newContentElement.wizardItems.common.elements.image.tt_content_defValues.imagecols=1

and it works perfect!

#8

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/15118

#9

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/15118

#10

Updated by Gerrit Code Review about 8 years ago

Patch set 4 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/15118

#11

Updated by Gerrit Code Review about 8 years ago

Patch set 5 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/15118

#12

Updated by Gerrit Code Review almost 8 years ago

Patch set 6 for branch master has been pushed to the review server.
It is available at https://review.typo3.org/15118

#13

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-1 has been pushed to the review server.
It is available at https://review.typo3.org/21980

#14

Updated by Gerrit Code Review almost 8 years ago

Patch set 1 for branch TYPO3_6-0 has been pushed to the review server.
It is available at https://review.typo3.org/21981

#15

Updated by Jigal van Hemert almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF