Bug #63049

TCAdefaults imagecols doesn't work

Added by Martin Huber over 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2014-11-18
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This issue: https://forge.typo3.org/issues/41434
exists in 6.2

Creating an element like text and switch type to text&image, imagecols always show "2" (the core default and not the setting from TCAdefaults.tt_content.imagecols


Related issues

Related to TYPO3 Core - Bug #41434: userTSconfig: TCAdefaults.tt_content.imagecols = 1 does not always work Closed 2012-09-27
Related to TYPO3 Core - Bug #75233: TCAdefaults imagecols doesn't work always Closed 2016-03-22
Related to TYPO3 Core - Bug #77918: imagecols = 1 doesn't work, if disabled in BE interface New 2016-09-12

History

#1 Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from New to Closed

I am not able to reproduce with 6.2.14 or 7 (latest master)
Steps done:
1) put

TCAdefaults.tt_content.imagecols = 1

into the TS config field of the user "editor"
2) log as editor
3) create new CE, type "images"

result:

in the "appereance" tab, the "Number of Columns" dropdown is set to 1 instead of 2.

so I'll close the issue; if you think that this is the wrong decision (because more tests must be performed) or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

#2 Updated by Chris K. about 4 years ago

Riccardo De Contardi wrote:

I am not able to reproduce with 6.2.14 or 7 (latest master)
Steps done:
1) put
[...]
into the TS config field of the user "editor"
2) log as editor
3) create new CE, type "images"

result:

in the "appereance" tab, the "Number of Columns" dropdown is set to 1 instead of 2.

so I'll close the issue; if you think that this is the wrong decision (because more tests must be performed) or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

If you create new CE -> type "textmedia" (TYPO3 7.6) it works fine.

But creat new CE -> type "header" (for example), save and now switch to type "textmedia". The "Number of Columns" is 2 and not 1.

Also available in: Atom PDF