Bug #42616

Install new system extensions during upgrade process fails

Added by Nicole Cordes almost 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2012-11-02
Due date:
% Done:

100%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
hard
Is Regression:
Sprint Focus:

Description

If you try to update your system from 4.7 to current master the second step "Install System Extensions" fails because of missing extensionmanager tables. So we have to push up the initialisation process from EM and adopt it to include ext_tables.sql as well (at the moment only the file ext_tables_static+adt.sql is executed).


Related issues

Related to TYPO3 Core - Bug #42560: upgrade wizard 'em extension repository' fails Closed 2012-10-31

Associated revisions

Revision 588fc918 (diff)
Added by Nicole Cordes almost 8 years ago

[BUGFIX] Install new system extensions during upgrade process fails

If you try to update your system from 4.7 to current master the second
step "Install System Extensions" fails because of missing extensionmanager
tables.

So we have to push up the initialisation process from EM and adopt
it to include ext_tables.sql as well (at the moment only the file
ext_tables_static+adt.sql is processed).

Change-Id: I5cd4616e5bccd06e86fa3ae4fbde8a083afa428f
Fixes: #42616
Releases: 6.0
Reviewed-on: http://review.typo3.org/16153
Reviewed-by: Mattias Nilsson
Reviewed-by: Wouter Wolters
Reviewed-by: Helmut Hummel
Tested-by: Helmut Hummel

History

#1 Updated by Nicole Cordes almost 8 years ago

  • Assignee set to Nicole Cordes

#2 Updated by Oliver Hader almost 8 years ago

  • Complexity set to hard

#3 Updated by Oliver Hader almost 8 years ago

  • Status changed from New to Accepted

#4 Updated by Nicole Cordes almost 8 years ago

This is the error

Uncaught TYPO3 Exception
#1247602160: Table 'typo3_update.tx_extensionmanager_domain_model_extension' doesn't exist: SELECT tx_extensionmanager_domain_model_extension.* FROM tx_extensionmanager_domain_model_extension WHERE ((tx_extensionmanager_domain_model_extension.extension_key = 'recycler' AND tx_extensionmanager_domain_model_extension.version = '1.2.0') AND tx_extensionmanager_domain_model_extension.review_state >= '0') LIMIT 1

#5 Updated by Gerrit Code Review almost 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16153

#6 Updated by Gerrit Code Review almost 8 years ago

Patch set 2 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16153

#7 Updated by Gerrit Code Review almost 8 years ago

Patch set 3 for branch master has been pushed to the review server.
It is available at http://review.typo3.org/16153

#8 Updated by Felix Oertel almost 8 years ago

Confirmed still broken ...

#9 Updated by Nicole Cordes almost 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF