Bug #43509

"Migrate all file relations from tt_content.image and pages.media" fails on missing file

Added by Adrian Dymorz over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2012-12-02
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Trying to run the "Upgrade Wizard" part "Migrate all file relations from tt_content.image and pages.media" i get the error message "Oops, an error occurred!" shown in the T3 standard FE error screen.

Looking at the "Administration log" I see the following errors:
23:25:51 [0]@LIVE [5] [0] Core: Exception handler (WEB): Uncaught TYPO3 Exception: | TYPO3\CMS\Core\Resource\Exception\FileDoesNotExistException thrown in file /home/adrianfi/typo3source/typo3_src-6.0.0/typo3/sysext/core/Classes/Resource/Driver/AbstractDriver.php in line 399. Requested URL: http://adrian.dymorz.ch/[testdir]/typo3/install/index.php?TYPO3_INSTALL[type]=update
23:25:51 [0]@LIVE [5] [0] Core: Error handler (BE): PHP Warning: rename(/home/adrianfi/public_html/adriandymorzch/[testdir]/uploads/pics/Blaue_Berge.jpg,/home/adrianfi/public_html/adriandymorzch/[testdir]/fileadmin/_migrated/pics/Blaue_Berge.jpg): No such file or directory in /home/adrianfi/typo3source/typo3_src-6.0.0/typo3/sysext/install/Classes/Updates/TceformsUpdateWizard.php line 198

The error looks obvious, the file seems to be missing. I wonder why a missing file breaks the whole migration process.


Related issues

Related to TYPO3 Core - Bug #42882: FileDoesNotExistException thrown in update Closed 2012-11-12

History

#1 Updated by Andreas Wolf over 6 years ago

I guess this will be fixed by the patch for issue #42882. Could you test this one and give feedback in Gerrit? I'd like to get this fixed for 6.0.1.

#2 Updated by Adrian Dymorz over 6 years ago

Thank you for your reply. I just tested the patch for issue #42882. With this patch applied, the error I reported is solved.

#3 Updated by Stefan Neufeind over 6 years ago

On gerrit in review for #42882 it was mentioned that the fix under review there seems to also fix this issue here. Please consider in tests or when finally closing these bugs.

#4 Updated by Dmitry Dulepov over 6 years ago

  • Status changed from New to Closed

Duplicate of #42882.

Also available in: Atom PDF