Feature #44779

Epic #61834: Create future proof Content Element with strong default

Task #61836: Reorganize Content Element properties within backend Extension

Task #61842: Refactor CSS-Styled-Content + Content Elements

No css_styled_content on content element TABLE

Added by Patrick Crausaz over 6 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-01-24
Due date:
% Done:

0%

PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Not able to configurate any HTML tag of a table content element with typoscript.
You can add a class to <table> if you set it to the flexform, but only one class. Two classes won't pass the validation.

In css_styld_content points an userFunc to tx_cssstyledcontent_pi1->render_table where the configuration is taken from pi_flexform field.
This is very unflexible, because if I want to change something on a table, I have to write an extension to overwrite the pi_flexform value of that content element. other elements are rendered with typoscript, not with userFunc.


Related issues

Related to TYPO3 Core - Bug #55470: CE Table does not allow multiple css classes Closed 2014-01-30

History

#1 Updated by Oliver Hader over 6 years ago

  • Status changed from New to Needs Feedback

Looks like you're talking about two different issues, right?
The "Additional CSS Class" issue can be confirmed, since the input field in the backend removes whitespace (to be fixed in TCA "eval" part).

Concerning the Flexform thingy, I'd like to ask you to add an example of TypoScript to see, what you're aiming for. Thanks

#2 Updated by Oliver Hader over 6 years ago

  • Subject changed from No css_styled_content on tables to No css_styled_content on content element TABLE

#3 Updated by Patrick Crausaz over 6 years ago

The thing is that the content element TABLE is rendered by the userFunc tx_cssstyledcontent_pi1->render_table (and there are hardcoded classed in this PHP function by the way...)
So you cannot configurate anything about the table.

If for example you want to change something of the content element Image or Text, you just overwrite the css_styled_content typoscript.
Look at "tt_content.stdWrap.innerWrap.cObject.default"
- If I dont want my text is rendered with id="anything" I will overwrite it here.
- If I want my Image is rendered with span instead of div, I overwrite it.
- If I want to change anything about my table markup, I go to "typo3/sysext/css_styled_content/pi1/class.tx_cssstyledcontent_pi1.php" and do my own PHP. And I need to do it again in any TYPO3 update.

#4 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to New

#5 Updated by Felix Kopp almost 5 years ago

  • Parent task set to #61842

#6 Updated by Georg Ringer almost 5 years ago

  • Status changed from New to Resolved

resolved with #55470

whitespace not trimmed anymore

#7 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF