Bug #45067

Images in Content Elements not visible for non-admin users

Added by Wolfgang Wagner almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-02-01
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If an admin creates an CE "Images" or "Text w/ images", than the images are not visible for an non-admin user, even if he has the correct rights to edit these elements.
But the non-admin user can add new images without problem, he only can not see images added by the admin.

I have added a screenshot.


Files

admin-non-admin.png (26.9 KB) admin-non-admin.png Wolfgang Wagner, 2013-02-01 11:42
set-pids.php (1.31 KB) set-pids.php Christian Bernet, 2013-02-20 14:00
#1

Updated by Stefan Froemken almost 9 years ago

Hello Wolfgang,

did you give backend groups the rights of following tables?

- File Storage (sys_file_storage)
- File (sys_file)
- File Reference (sys_file_reference)

Stefan

#2

Updated by Wolfgang Wagner almost 9 years ago

  • % Done changed from 0 to 100

Thx, this solved the problem ;)

Issue can be closed.

#3

Updated by Jigal van Hemert almost 9 years ago

  • Status changed from New to Closed

Closed per request of reporter.

#4

Updated by Tobias H. almost 9 years ago

Hi,

i have almost the same problem. The editor can not see images in "old" CE elements created before the upgrade from 4.5.x. If a admin creates a new Image element, the editor can see them. So the group rights are ok, but maybe not the same rights for the migrated content.

I think it has something to do with the upgrade. Can someone check this and maybe reopen the bug?

#5

Updated by Christian Bernet almost 9 years ago

We have the same problem.
i think we shoud open a new Issue, because this Issue is not the same bug.

#6

Updated by Christian Bernet almost 9 years ago

There is a open issue (http://forge.typo3.org/issues/44752) already for this.
I have wrote a little script to generate the ids (is attached).

Also available in: Atom PDF