Bug #45634

Element browser shows no files if value for allowed in TCA is *

Added by Axel Brand over 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2013-02-20
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In my TCA of an extension:

'file' => array(
            'exclude' => 0,
            'label' => 'LLL:EXT:gehc_products/Resources/Private/Language/locallang_db.xlf:tx_gehcproducts_domain_model_download.file',
            'config' => array(
                'type' => 'group',
                'internal_type' => 'file',
                'uploadfolder' => 'uploads/tx_gehcproducts',
                'allowed' => '*',
                'disallowed' => 'php',
                'size' => 5,
            ),
        ),

If allowed is set to '*', there are no files shown in the element browser.
I set it to 'pdf', then all pdf-files are shown.

But I need the wildcard.

History

#1 Updated by Wouter Wolters about 6 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (6.0.3)

From the documentation at http://docs.typo3.org/typo3cms/TCAReference/Reference/Columns/Group/Index.html it says:

'disallowed':
Default value is '*' which means that anything file-extension which is not allowed is denied.

If you set this value (to for example "php,php3") AND the "allowed" key is an empty string all extensions are permitted except ".php" and ".php3" files

Can you try to remove the * and try it with an empty string?

#2 Updated by Axel Brand about 6 years ago

It works with an empty string.
Fine...thank you!

#3 Updated by Martin Eberle about 6 years ago

Same problem in 6.0.5.

An empty string instead of an asterisk works.

#4 Updated by Kai Tallafus almost 6 years ago

I wonder if this is a bug or a feature? Why did the behaviour change? Seems not really logic to me...

#5 Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New
  • Is Regression set to No

Should we accept the asterix in TCA on file.config.allowed? I think yes, as it is accepted in file.config.disallowed.

#6 Updated by Stefan Busemann over 4 years ago

In the past (4.5) the setting "*" worked. So in my eyes this is a bug, which should be added to 6.2

#7 Updated by Wouter Wolters about 4 years ago

  • Status changed from New to Needs Feedback

I can't reproduce this on current 6.2 and master.

Can you recheck if this is still a problem for you?

#8 Updated by Axel Brand about 4 years ago

I can't reproduce the bug anymore, too.
Thanx!

#9 Updated by Wouter Wolters about 4 years ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF