Bug #46090

Contentobject data Image/Link broken or missing

Added by Martin Muzatko almost 7 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-03-07
Due date:
% Done:

0%

TYPO3 Version:
6.0
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

On update to 6.0.3, the contentobject data did not return any expected values ($this->cObj->data;)

The same issue can be found on stackoverflow -> http://stackoverflow.com/questions/15250351/missing-image-in-typo3-this-contentobj-in-6-0-3

$this->contentObj = $this->configurationManager->getContentObject();
$data = $this->contentObj->data;
print_r($data);

This will return a tt_content - object including image => /path/to/image. Everything fine.

[bodytext] => Lorem ipsum dolor 
[image] => ../../fileadmin/user_upload/images/businessman.jpg

Today changing source to TYPO3 6.0.3 everything the same but the image is just a "1".

[bodytext] => Lorem ipsum dolor
[image] => 1


Related issues

Related to TYPO3 Core - Bug #46067: Image rendering fails when using 'image' or 'media' field with own CEs (CType) Closed 2013-03-06

History

#1 Updated by Martin Muzatko almost 7 years ago

  • Project changed from Fluid to Extbase MVC Framework
  • Category deleted (Fluid)
  • Target version deleted (Fluid 6.0)

#2 Updated by Marc Bastian Heinrichs almost 7 years ago

  • Subject changed from Data Image/Link broken or missing to Contentobject data Image/Link broken or missing
  • Priority changed from Must have to Should have
  • Has patch set to No

#3 Updated by Marc Bastian Heinrichs almost 7 years ago

  • Status changed from New to Needs Feedback

You mean you enabled the normal image field for a plugin content object?

The data array is comming direct from core and was not touched by extbase.
IMHO this should be the number of attached images because the image
field is a reference record to the file record since 6.0.

#4 Updated by Marc Bastian Heinrichs almost 7 years ago

  • Project changed from Extbase MVC Framework to TYPO3 Core

#5 Updated by Marc Bastian Heinrichs almost 7 years ago

Some more details are needed:
  • did you start the site with 6.0 did you updated from a 4.x?
  • if update, did you run the wizard to transform the images to file references
  • changes in tca configuration?

#6 Updated by Tobias Wollender almost 7 years ago

I noticed this problem also. Started the site with a 6.0 installation - no update from a 4.x. Also no changes in the TCA config. I just want to render a new content element (own ctype) with fluid - using the standard tt_content image field. With 6.0.2 [image] contained the url, after an update to 6.0.3 it contains "1". Actually this is the amount of images that were selected in the content element.

#7 Updated by Tobias Wollender almost 7 years ago

I searched for the change that introduced the new behaviour and found it: http://forge.typo3.org/issues/45415 - if I use typo3/sysext/core/Classes/Resource/Service/FrontendContentAdapterService.php from 6.0.2 everything works like before. Don't know if this changed behaviour is intended or just a side effect that can be fixed.

#8 Updated by Tilo Baller almost 7 years ago

Do you get you right, that you are using a custom content element, meaning a new CType in tt_content or another table?
Than it's the problem described here: #46067.

#9 Updated by Tobias Wollender almost 7 years ago

Thank you for the hint on #46067. That's exactly the problem in my case.

#10 Updated by Tobias Wollender over 6 years ago

In my extension I solved this problem with an own fal viewhelper now. You can see the solution in this little extension: https://github.com/tliegl/contentelements

#11 Updated by Alexander Opitz over 6 years ago

  • TYPO3 Version set to 6.0
  • Is Regression set to No

Hi,

is this issue solved with newer versions of TYPO3 CMS? Latest one is 6.1.5 at the moment.

#12 Updated by Alexander Opitz about 6 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this ticket.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF