Bug #46096

Update 4.5.25: Network connection error, Apache says " Cannot redeclare class t3lib_div"

Added by Bert Hiddink almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2013-03-07
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
5.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello,

Just updated from 4.5.22 to 4.5.25, set-up is Apache/PHP 5.3/TYPO3 4.5.x with APC as accelerator...

When I update core to 4.5.25 and try to login the BE, I get a Network connection error, can not connecto to database...

The Apache log says:
[apc-error] Cannot redeclare class t3lib_div in /var/www/typo3_src-4.5.25/typo3/init.php on line 200

Any ideas?

Getting back to 4.5.22 makes it work again...

Thanks and regards,
Bert

#1

Updated by Jigal van Hemert almost 9 years ago

  • Assignee deleted (Jigal van Hemert)

Please do not assign issues to people directly. If someone starts working on an issue he/she will assign it to him/herself. Otherwise everybody will assume that the assignee is working on it already.

#2

Updated by Bert Hiddink almost 9 years ago

Hello Jigal,

Sorry for that auto-assignment...

Thanks,
Bert

#3

Updated by Bert Hiddink almost 9 years ago

Hello,

The problem with 4.5.25 does not happen when updating to 4.7.10 (same set-up, same server)...

Thanks,
Bert

#4

Updated by Christian Kuhn almost 9 years ago

  • Status changed from New to Needs Feedback

this is probably an apc cache problem, looks like apc does not handle changed source files very well in your case. please try to restart your webserver and see if the issue is solved then.

#5

Updated by Bert Hiddink almost 9 years ago

Hello Christian,

Yes, I can confirm that restarting Apache resolved the problem...

Thanks!
Bert

#6

Updated by Benni Mack almost 9 years ago

  • Status changed from Needs Feedback to Closed

closing this issue, as it is related to APC cache.

Also available in: Atom PDF