Bug #46272

Typoscript CONTENT-Element orderBy doesn't consider stdWrap

Added by Michel Baeriswyl over 8 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2013-03-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I would like to apply stdWrap to the attribute orderBy for the CONTENT-element. Neither something like

temp.catcontent = CONTENT
temp.catcontent {
  table = tx_dam
  select {
    pidInList = 134
    selectFields = *
    join = tx_dam_mm_cat
    where = tx_dam.uid = tx_dam_mm_cat.uid_local
    andWhere = tx_dam_mm_cat.uid_foreign = ###category###
    orderBy = ###orderby###
    markers {
      category.data = register:category
      orderby.data = register:orderby
    }
}

nor
orderBy.dataWrap = {GP:orderby}

works.


Related issues

Is duplicate of TYPO3 Core - Feature #20508: Enable stdWrap on select properties groupBy and orderByClosedOliver Hader2009-05-26

Actions
#1

Updated by Georg Ringer over 6 years ago

  • Status changed from New to Resolved
  • Is Regression set to No

I checked the code and stdWrap is there. the mentioned issue is #20508. so that should also be fine in 4.5!

Feel free to reopen if you still think this is valid!

#2

Updated by Benni Mack almost 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF